{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-10168 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-10168 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-10168 is a high-severity vulnerability in n/a, published on 3 May 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-10168 and fix it if it is affected.\n\nWhat it is: CVE-2018-10168 is a high-severity vulnerability in n/a, published on 3 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-10168 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10168/ (Markdown: https://insights.sbomify.com/CVE-2018-10168/index.md)","id":"CVE-2018-10168","markdown":"https://insights.sbomify.com/CVE-2018-10168/index.md","name":"CVE-2018-10168","record":{"aliases":["GHSA-cp86-86qv-hq88"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"TP-Link EAP Controller","requires_auth":"low_privilege","summary":"Low-privilege users can escalate to Administrator privileges via the Web API in TP-Link EAP and Omada Controllers.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"eap_controller","vendor":"tp-link"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"TP-Link EAP Controller and Omada Controller versions 2.5.4_Windows/2.6.0_Windows do not control privileges for usage of the Web API, allowing a low-privilege user to make any request as an Administrator. This is fixed in version 2.6.1_Windows.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Privilege escalation in n/a","id":"CVE-2018-10168","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2018"},"n_packages":0,"n_references":2,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2018-10169"},"packages":[],"prev":{"headline":"Hardcoded credentials in n/a","id":"CVE-2018-10167"},"products":["n/a"],"published":"2018-05-03","related":[{"cvss_score":9.8,"headline":"TP-Link EAP Controller versions 2.5.3 and earlier lack RMI authentication","id":"CVE-2018-5393","kev_date_added":null,"published":"2018-09-28"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-10166","kev_date_added":null,"published":"2018-05-03"},{"cvss_score":7.5,"headline":"Hardcoded credentials in n/a","id":"CVE-2018-10167","kev_date_added":null,"published":"2018-05-03"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2018-10164","kev_date_added":null,"published":"2018-05-03"},{"cvss_score":5.4,"headline":"Cross-site scripting in n/a","id":"CVE-2018-10165","kev_date_added":null,"published":"2018-05-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Low-privilege users can escalate to Administrator privileges via the Web API in TP-Link EAP and Omada Controllers.","url":"https://insights.sbomify.com/CVE-2018-10168/"}