# CVE-2018-10168: Privilege escalation in n/a

> Low-privilege users can escalate to Administrator privileges via the Web API in TP-Link EAP and Omada Controllers.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 3 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-cp86-86qv-hq88

## What is CVE-2018-10168?

CVE-2018-10168 is a high-severity vulnerability in n/a, published on 3 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

TP-Link EAP Controller and Omada Controller versions 2.5.4_Windows/2.6.0_Windows do not control privileges for usage of the Web API, allowing a low-privilege user to make any request as an Administrator. This is fixed in version 2.6.1_Windows.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2018-10168?

It affects 1 product.


Products: Tp-Link Eap Controller.

## How do I fix CVE-2018-10168?

No fix has been published for CVE-2018-10168 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-10168 being exploited?

There is no known exploitation of CVE-2018-10168 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-5393](https://insights.sbomify.com/CVE-2018-5393/): TP-Link EAP Controller versions 2.5.3 and earlier lack RMI authentication (critical 9.8)
- [CVE-2018-10166](https://insights.sbomify.com/CVE-2018-10166/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2018-10167](https://insights.sbomify.com/CVE-2018-10167/): Hardcoded credentials in n/a (high 7.5)
- [CVE-2018-10164](https://insights.sbomify.com/CVE-2018-10164/): Cross-site scripting in n/a (medium 5.4)
- [CVE-2018-10165](https://insights.sbomify.com/CVE-2018-10165/): Cross-site scripting in n/a (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10168 and fix it if it is affected.

What it is: CVE-2018-10168 is a high-severity vulnerability in n/a, published on 3 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-10168 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10168/ (Markdown: https://insights.sbomify.com/CVE-2018-10168/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10168
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10168
- OSV: https://osv.dev/vulnerability/CVE-2018-10168

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10168/
Summaries are generated and may contain mistakes; the official description above is the record.
