{"answers":{"affected":"2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-10188 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 4.8.0.1 or later.","what":"CVE-2018-10188 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 19 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-10188 and fix it if it is affected.\n\nWhat it is: CVE-2018-10188 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 19 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-10188 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.0.1\n- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10188/ (Markdown: https://insights.sbomify.com/CVE-2018-10188/index.md)","id":"CVE-2018-10188","markdown":"https://insights.sbomify.com/CVE-2018-10188/index.md","name":"CVE-2018-10188","record":{"aliases":["CVE-2018-1000555","DEBIAN-CVE-2018-10188","GHSA-v6fp-h79x-9rqc","openSUSE-SU-2018:1058-1","openSUSE-SU-2018:1059-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Database administration tool","requires_auth":"none","summary":"Cross-site request forgery in phpMyAdmin allows attackers to execute arbitrary SQL statements via crafted requests.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmyadmin","vendor":"phpmyadmin"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.","ecosystems":["Packagist","SUSE:Package Hub 12"],"exploits":{"exploitdb":1,"first_seen":"2018-04-23","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-04-23","kind":"exploitdb","ref":"44496","stars":null,"title":"phpMyAdmin 4.8.0 \u003c 4.8.0-1 - Cross-Site Request Forgery"}],"tier":"poc_unverified"},"has_fix":true,"headline":"phpMyAdmin CSRF vulnerability allowing arbitrary SQL execution","id":"CVE-2018-10188","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"phpmyadmin:phpmyadmin","products":["phpmyadmin:phpmyadmin"],"type":"csrf","year":"2018"},"n_packages":4,"n_references":4,"next":{"headline":"Mautic Sessions could be hijacked due to tracking contacts by an auto-incremented ID","id":"CVE-2018-10189"},"packages":[{"ecosystem":"Packagist","fixed":["4.8.0.1"],"introduced":["4.8"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-v6fp-h79x-9rqc"},{"ecosystem":"Packagist","fixed":["4.8.0.1"],"introduced":["4.8"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-v6fp-h79x-9rqc"},{"ecosystem":"SUSE:Package Hub 12","fixed":["4.8.0.1-20.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/suse/phpMyAdmin\u0026distro=SUSE%20Package%20Hub%2012","source":"openSUSE-SU-2018:1058-1"},{"ecosystem":"SUSE:Package Hub 12","fixed":["4.8.0.1-20.1"],"introduced":["0"],"last_affected":[],"package":"phpMyAdmin","purl":"pkg:rpm/suse/phpMyAdmin\u0026distro=SUSE%20Package%20Hub%2012","source":"openSUSE-SU-2018:1059-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-10187"},"products":["n/a"],"published":"2018-04-19","related":[{"cvss_score":10,"headline":"Misconfiguration in n/a","id":"CVE-2008-7251","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"phpMyAdmin unsafely handles temporary files","id":"CVE-2008-7252","kev_date_added":null,"published":"2010-01-19"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-0203","kev_date_added":null,"published":"2007-01-11"},{"cvss_score":10,"headline":"Command injection in n/a","id":"CVE-2004-1147","kev_date_added":null,"published":"2004-12-15"},{"cvss_score":9.8,"headline":"phpmyadmin contains SQL Injection vulnerability","id":"CVE-2020-22452","kev_date_added":null,"published":"2023-01-26"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-11768","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"phpMyAdmin SQL injection in Designer feature","id":"CVE-2019-6798","kev_date_added":null,"published":"2019-01-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site request forgery in phpMyAdmin allows attackers to execute arbitrary SQL statements via crafted requests.","url":"https://insights.sbomify.com/CVE-2018-10188/"}