{"answers":{"affected":"It affects 9 products.","exploited":"There is no known exploitation of CVE-2018-10194 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-10194 is a high-severity vulnerability in Artifex Ghostscript, published on 18 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-10194 and fix it if it is affected.\n\nWhat it is: CVE-2018-10194 is a high-severity vulnerability in Artifex Ghostscript, published on 18 Apr 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-10194 in the wild and no public exploit code.\n\nAffected product: Artifex Ghostscript. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10194/ (Markdown: https://insights.sbomify.com/CVE-2018-10194/index.md)","id":"CVE-2018-10194","markdown":"https://insights.sbomify.com/CVE-2018-10194/index.md","name":"CVE-2018-10194","record":{"aliases":["ALPINE-CVE-2018-10194","DEBIAN-CVE-2018-10194","DLA-1363-1","GHSA-x8vv-69hx-8rmh","MGASA-2018-0219","SUSE-SU-2018:1332-1","SUSE-SU-2018:1884-1","UBUNTU-CVE-2018-10194"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ghostscript pdfwrite","requires_auth":"none","summary":"Remote attackers can cause a denial of service via crafted PDF documents due to integer overflows in Ghostscript's pdfwrite component.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ghostscript","vendor":"artifex"},{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_server_aus","vendor":"redhat"},{"product":"enterprise_linux_server_eus","vendor":"redhat"},{"product":"enterprise_linux_server_tus","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"The set_text_distance function in devices/vector/gdevpdts.c in the pdfwrite component in Artifex Ghostscript through 9.22 does not prevent overflows in text-positioning calculation, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted PDF document.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Module for Basesystem 15","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2018-10194","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"artifex:ghostscript","products":["artifex:ghostscript","canonical:ubuntu_linux","debian:debian_linux","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_server_aus","redhat:enterprise_linux_server_eus","redhat:enterprise_linux_server_tus","redhat:enterprise_linux_workstation"],"type":"integer_overflow","year":"2018"},"n_packages":5,"n_references":7,"next":{"headline":"Integer overflow in n/a","id":"CVE-2018-10195"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["9.15-23.10.2"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:1332-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["9.23-3.3.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2018:1884-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["9.15-23.10.2"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:1332-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["9.15-23.10.2"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:1332-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["9.15-23.10.2"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:1332-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2018-10193"},"products":["n/a"],"published":"2018-04-18","related":[{"cvss_score":7.8,"headline":"Artifex Ghostscript Type Confusion","id":"CVE-2017-8291","kev_date_added":"2022-05-24","published":"2017-04-27"},{"cvss_score":9.9,"headline":"Command injection in ghostscript","id":"CVE-2021-3781","kev_date_added":null,"published":"2022-02-16"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27831","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27832","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27836","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"An issue was discovered in Artifex Ghostscript before 10.05.0.","id":"CVE-2025-27837","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-36773","kev_date_added":null,"published":"2024-02-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via crafted PDF documents due to integer overflows in Ghostscript's pdfwrite component.","url":"https://insights.sbomify.com/CVE-2018-10194/"}