{"answers":{"affected":"2 open source packages ship an affected version, including rainlab/user-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-10366 in the wild and no public exploit code.","fix":"Upgrade rainlab/user-plugin to 1.5.0 or later.","what":"CVE-2018-10366 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-10366 and fix it if it is affected.\n\nWhat it is: CVE-2018-10366 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Apr 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-10366 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rainlab/user-plugin (Packagist): affected all versions; fixed in 1.5.0\n- rainlab/user-plugin (Packagist): affected all versions; fixed in 1.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10366/ (Markdown: https://insights.sbomify.com/CVE-2018-10366/index.md)","id":"CVE-2018-10366","markdown":"https://insights.sbomify.com/CVE-2018-10366/index.md","name":"CVE-2018-10366","record":{"aliases":["GHSA-x5jc-34xf-c24q"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"October CMS plugin","requires_auth":"none","summary":"Cross-site scripting in the Users plugin name field allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"user","vendor":"user_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in the Users (aka Front-end user management) plugin 1.4.5 for October CMS. XSS exists in the name field.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2018-04-26","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2018-04-26","kind":"exploitdb","ref":"44546","stars":null,"title":"October CMS User Plugin 1.4.5 - Persistent Cross-Site Scripting"}],"tier":"poc_unverified"},"has_fix":true,"headline":"User Plugin for October CSS Allows XSS","id":"CVE-2018-10366","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-10367"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"rainlab/user-plugin","purl":null,"source":"GHSA-x5jc-34xf-c24q"},{"ecosystem":"Packagist","fixed":["1.5.0"],"introduced":["0"],"last_affected":[],"package":"rainlab/user-plugin","purl":"pkg:composer/rainlab/user-plugin","source":"GHSA-x5jc-34xf-c24q"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-10365"},"products":["n/a"],"published":"2018-04-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Cross-site scripting in the Users plugin name field allows attackers to inject scripts, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2018-10366/"}