CVE-2018-1044 Moodle Privilege escalation in quiz web services
Students can view prohibited quiz results via web services, exposing sensitive assessment data in Moodle installations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1044?
CVE-2018-1044 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Moodle 3.x, quiz web services allow students to see quiz results when it is prohibited in the settings.
Weakness: CWE-200
Which versions are affected by CVE-2018-1044?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.10 |
moodle/moodle Packagist | From 3.1 | 3.1.10 |
moodle/moodle Packagist | From 3.2 | 3.2.7 |
moodle/moodle Packagist | From 3.2 | 3.2.7 |
moodle/moodle Packagist | From 3.3 | 3.3.4 |
moodle/moodle Packagist | From 3.3 | 3.3.4 |
2 more packages
moodle/moodle Packagist | From 3.4 | 3.4.1 |
moodle/moodle Packagist | From 3.4 | 3.4.1 |
Products include Moodle Moodle.
How do I fix CVE-2018-1044?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.10, 3.2.7, 3.3.4 or 3.4.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2018-1044 being exploited?
There is no known exploitation of CVE-2018-1044 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-332g-xh34-5c96, UBUNTU-CVE-2018-1044.