CVE-2018-1045 Moodle XSS Vulnerability
An attacker can inject malicious scripts via calendar event names in Moodle, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1045?
CVE-2018-1045 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Jan 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Moodle 3.x, there is XSS via a calendar event name.
Weakness: CWE-79
Which versions are affected by CVE-2018-1045?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.10 |
moodle/moodle Packagist | From 3.1 | 3.1.10 |
moodle/moodle Packagist | From 3.2 | 3.2.7 |
moodle/moodle Packagist | From 3.2 | 3.2.7 |
moodle/moodle Packagist | From 3.3 | 3.3.4 |
moodle/moodle Packagist | From 3.3 | 3.3.4 |
Products include Moodle Moodle.
How do I fix CVE-2018-1045?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.10, 3.2.7 or 3.3.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1045 being exploited?
There is no known exploitation of CVE-2018-1045 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-595j-wpfg-23w4, UBUNTU-CVE-2018-1045.