# CVE-2018-10657: Matrix Synapse DoS

> Attackers can cause denial of service in Matrix Synapse by injecting malicious events with extreme depth values, rendering rooms unusable.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-vmcc-4p4x-x7wg, PYSEC-2026-846, UBUNTU-CVE-2018-10657

## What is CVE-2018-10657?

CVE-2018-10657 is a high-severity denial of service vulnerability in n/a, published on 2 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Matrix Synapse before 0.28.1 is prone to a denial of service flaw where malicious events injected with depth = 2^63 - 1 render rooms unusable, related to federation/federation_base.py and handlers/message.py, as exploited in the wild in April 2018.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-10657?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 0.28.1 |
| `matrix-synapse` | PyPI | All versions | 0.28.1 |
| `matrix-synapse` | PyPI | All versions | 0.28.1 |

Products: Matrix Synapse.

## How do I fix CVE-2018-10657?

Upgrade matrix-synapse to 0.28.1 or later.

## Is CVE-2018-10657 being exploited?

There is no known exploitation of CVE-2018-10657 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10657 and fix it if it is affected.

What it is: CVE-2018-10657 is a high-severity denial of service vulnerability in n/a, published on 2 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-10657 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 0.28.1
- matrix-synapse (PyPI): affected all versions; fixed in 0.28.1
- matrix-synapse (PyPI): affected all versions; fixed in 0.28.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10657/ (Markdown: https://insights.sbomify.com/CVE-2018-10657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10657
- OSV: https://osv.dev/vulnerability/CVE-2018-10657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10657/
Summaries are generated and may contain mistakes; the official description above is the record.
