# CVE-2018-10704: Cross-site Scripting in yii2cmf

> Cross-site scripting vulnerability in yidashi yii2cmf allows attackers to inject malicious scripts via the search parameter.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Mar 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mvrg-5c4w-7qv4

## What is CVE-2018-10704?

CVE-2018-10704 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yidashi yii2cmf 2.0 has XSS via the /search q parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-10704?

2 open source packages ship an affected version, including yidashi/yii2cmf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yidashi/yii2cmf` | Packagist | All versions | 2.0.2 |
| `yidashi/yii2cmf` | Packagist | All versions | 2.0.2 |

Products: Yii2cmf Project Yii2cmf.

## How do I fix CVE-2018-10704?

Upgrade yidashi/yii2cmf to 2.0.2 or later.

## Is CVE-2018-10704 being exploited?

There is no known exploitation of CVE-2018-10704 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10704 and fix it if it is affected.

What it is: CVE-2018-10704 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-10704 in the wild and no public exploit code.

Affected packages and fixed versions:
- yidashi/yii2cmf (Packagist): affected all versions; fixed in 2.0.2
- yidashi/yii2cmf (Packagist): affected all versions; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10704/ (Markdown: https://insights.sbomify.com/CVE-2018-10704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10704
- OSV: https://osv.dev/vulnerability/CVE-2018-10704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10704/
Summaries are generated and may contain mistakes; the official description above is the record.
