{"answers":{"affected":"It affects 6 products.","exploited":"There is no known exploitation of CVE-2018-10733 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-10733 is a medium-severity memory corruption vulnerability in Opensuse Leap, published on 4 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-10733 and fix it if it is affected.\n\nWhat it is: CVE-2018-10733 is a medium-severity memory corruption vulnerability in Opensuse Leap, published on 4 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-10733 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10733/ (Markdown: https://insights.sbomify.com/CVE-2018-10733/index.md)","id":"CVE-2018-10733","markdown":"https://insights.sbomify.com/CVE-2018-10733/index.md","name":"CVE-2018-10733","record":{"aliases":["DEBIAN-CVE-2018-10733","GHSA-8r7v-mcwp-4qfm","MGASA-2019-0003","SUSE-SU-2019:0720-1","SUSE-SU-2020:1687-1","UBUNTU-CVE-2018-10733","openSUSE-SU-2019:1120-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"libgxps library","requires_auth":"none","summary":"A heap-based buffer over-read in libgxps allows remote attackers to cause a denial of service via crafted input.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"libgxps","vendor":"gnome"},{"product":"leap","vendor":"opensuse"},{"product":"ansible_tower","vendor":"redhat"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"There is a heap-based buffer over-read in the function ft_font_face_hash of gxps-fonts.c in libgxps through 0.3.0. A crafted input will lead to a remote denial of service attack.","ecosystems":["SUSE:Linux Enterprise Module for Desktop Applications 15","SUSE:Linux Enterprise Server 12 SP4","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP5","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2018-10733","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap","redhat:ansible_tower","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"memory_corruption","year":"2018"},"n_packages":8,"n_references":5,"next":{"headline":"Information disclosure in n/a","id":"CVE-2018-10734"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15","fixed":["0.3.0-4.3.29"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/suse/libgxps\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015","source":"SUSE-SU-2019:0720-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP4","fixed":["0.2.2-10.3.5"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/suse/libgxps\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP4","source":"SUSE-SU-2020:1687-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["0.2.2-10.3.5"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/suse/libgxps\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2020:1687-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP4","fixed":["0.2.2-10.3.5"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/suse/libgxps\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP4","source":"SUSE-SU-2020:1687-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["0.2.2-10.3.5"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/suse/libgxps\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2020:1687-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP4","fixed":["0.2.2-10.3.5"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/suse/libgxps\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP4","source":"SUSE-SU-2020:1687-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["0.2.2-10.3.5"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/suse/libgxps\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2020:1687-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["0.3.0-lp150.3.3.2"],"introduced":["0"],"last_affected":[],"package":"libgxps","purl":"pkg:rpm/opensuse/libgxps\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1120-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2018-10732"},"products":["n/a"],"published":"2018-05-04","related":[{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2017-11590","kev_date_added":null,"published":"2017-07-24"},{"cvss_score":6.5,"headline":"Denial of service in n/a","id":"CVE-2018-10767","kev_date_added":null,"published":"2018-05-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A heap-based buffer over-read in libgxps allows remote attackers to cause a denial of service via crafted input.","url":"https://insights.sbomify.com/CVE-2018-10733/"}