CVE-2018-1081 Moodle Unauthenticated users can trigger custom messages to admin via paypal enrol script
Unauthenticated attackers can trigger admin email spam via PayPal IPN callback, potentially leading to phishing or social engineering attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1081?
CVE-2018-1081 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 4 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in Moodle 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions. Unauthenticated users can trigger custom messages to admin via paypal enrol script. Paypal IPN callback script should only send error emails to admin after request origin was verified, otherwise admin email can be spammed.
Weakness: CWE-79
Which versions are affected by CVE-2018-1081?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.11 |
moodle/moodle Packagist | From 3.1 | 3.1.11 |
moodle/moodle Packagist | From 3.2 | 3.2.8 |
moodle/moodle Packagist | From 3.2 | 3.2.8 |
moodle/moodle Packagist | From 3.3 | 3.3.5 |
moodle/moodle Packagist | From 3.3 | 3.3.5 |
2 more packages
moodle/moodle Packagist | From 3.4 | 3.4.2 |
moodle/moodle Packagist | From 3.4 | 3.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2018-1081?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.11, 3.2.8, 3.3.5 or 3.4.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1081 being exploited?
There is no known exploitation of CVE-2018-1081 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-v9xq-vh72-chr4, UBUNTU-CVE-2018-1081.