CVE-2018-1082 Moodle Improper Authentication
Suspended users with OAuth2 authentication can bypass account restrictions and log in to the Moodle site.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1082?
CVE-2018-1082 is a high-severity authentication bypass vulnerability in Moodle Moodle, published on 4 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in Moodle 3.4 to 3.4.1, and 3.3 to 3.3.4. If a user account using OAuth2 authentication method was once confirmed but later suspended, the user could still login to the site.
Which versions are affected by CVE-2018-1082?
4 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.3 | 3.3.5 |
moodle/moodle Packagist | From 3.3 | 3.3.5 |
moodle/moodle Packagist | From 3.4 | 3.4.2 |
moodle/moodle Packagist | From 3.4 | 3.4.2 |
Products include Moodle Moodle.
How do I fix CVE-2018-1082?
Upgrade moodle/moodle to a fixed version for your release line: 3.3.5 or 3.4.2.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2018-1082 being exploited?
There is no known exploitation of CVE-2018-1082 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-qh8m-6g4p-33h3, UBUNTU-CVE-2018-1082.