{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2018-10853 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-10853 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 11 Sep 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-10853 and fix it if it is affected.\n\nWhat it is: CVE-2018-10853 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 11 Sep 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-10853 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10853/ (Markdown: https://insights.sbomify.com/CVE-2018-10853/index.md)","id":"CVE-2018-10853","markdown":"https://insights.sbomify.com/CVE-2018-10853/index.md","name":"CVE-2018-10853","record":{"aliases":["DEBIAN-CVE-2018-10853","GHSA-vhcx-55j8-pv9c","SUSE-SU-2018:2684-1","UBUNTU-CVE-2018-10853"],"analysis":{"component_type":"kernel","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux kernel KVM","requires_auth":"low_privilege","summary":"An unprivileged guest user can escalate privileges within the guest OS due to missing privilege checks in KVM instruction emulation.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"linux_kernel","vendor":"linux"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"},{"id":"CWE-250","name":"Execution with Unnecessary Privileges"}],"description":"A flaw was found in the way Linux kernel KVM hypervisor before 4.18 emulated instructions such as sgdt/sidt/fxsave/fxrstor. It did not check current privilege(CPL) level while emulating unprivileged instructions. An unprivileged guest user/process could use this flaw to potentially escalate privileges inside guest.","ecosystems":["SUSE:Linux Enterprise Server 12 SP1-LTSS","SUSE:Linux Enterprise Server 12 SP2-LTSS","SUSE:Linux Enterprise Server 12-LTSS","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:Linux Enterprise Server for SAP Applications 12 SP2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in kernel","id":"CVE-2018-10853","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","linux:linux_kernel"],"type":"privilege_escalation","year":"2018"},"n_packages":5,"n_references":15,"next":{"headline":"Cross-site scripting in cloudforms","id":"CVE-2018-10854"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1-LTSS","fixed":["2-2.1"],"introduced":["0"],"last_affected":[],"package":"kgraft-patch-SLE12-SP1_Update_30","purl":"pkg:rpm/suse/kgraft-patch-SLE12-SP1_Update_30\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1-LTSS","source":"SUSE-SU-2018:2684-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP2-LTSS","fixed":["2-2.1"],"introduced":["0"],"last_affected":[],"package":"kgraft-patch-SLE12-SP2_Update_24","purl":"pkg:rpm/suse/kgraft-patch-SLE12-SP2_Update_24\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP2-LTSS","source":"SUSE-SU-2018:2684-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12-LTSS","fixed":["2-2.1"],"introduced":["0"],"last_affected":[],"package":"kgraft-patch-SLE12_Update_37","purl":"pkg:rpm/suse/kgraft-patch-SLE12_Update_37\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012-LTSS","source":"SUSE-SU-2018:2684-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["2-2.1"],"introduced":["0"],"last_affected":[],"package":"kgraft-patch-SLE12-SP1_Update_30","purl":"pkg:rpm/suse/kgraft-patch-SLE12-SP1_Update_30\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2018:2684-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["2-2.1"],"introduced":["0"],"last_affected":[],"package":"kgraft-patch-SLE12-SP2_Update_24","purl":"pkg:rpm/suse/kgraft-patch-SLE12-SP2_Update_24\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2018:2684-1"}],"prev":{"headline":"Information disclosure in sssd","id":"CVE-2018-10852"},"products":["kernel"],"published":"2018-09-11","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Linux"]},"summary":"An unprivileged guest user can escalate privileges within the guest OS due to missing privilege checks in KVM instruction emulation.","url":"https://insights.sbomify.com/CVE-2018-10853/"}