# CVE-2018-10855: Ansible exposes sensitive data in log files and on the terminal

> Ansible fails to honor the no_log flag for failed tasks, exposing sensitive data in logs and terminal output.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2018-10855, DEBIAN-CVE-2018-10855, GHSA-jwcc-j78w-j73w, MGASA-2018-0303, PYSEC-2018-42, RHSA-2018:1948, RHSA-2018:1949, RHSA-2018:2022, RHSA-2018:2079, RHSA-2018:2184, UBUNTU-CVE-2018-10855

## What is CVE-2018-10855?

CVE-2018-10855 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ansible 2.5 prior to 2.5.5, and 2.4 prior to 2.4.5, do not honor the no_log task flag for failed tasks. When the no_log flag has been used to protect sensitive data passed to a task from being logged, and that task does not run successfully, Ansible will expose sensitive data in log files and on the terminal of the user running Ansible.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2018-10855?

5 open source packages ship an affected version, including ansible. It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.4.0.0 | 2.4.5.0 |
| `ansible` | PyPI | From 2.4.0.0 | 2.4.5.0 |
| `ansible` | PyPI | From 2.5 | 2.5.5, 2.4.5.0 |
| `ansible` | PyPI | From 2.5.0a1 | 2.5.5 |
| `ansible` | PyPI | From 2.5.0a1 | 2.5.5 |
| `ansible` | Red Hat:ansible_engine:2.4::el7 | All versions | 0:2.4.5.0-1.el7ae |
| `ansible-doc` | Red Hat:ansible_engine:2.4::el7 | All versions | 0:2.4.5.0-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.5::el7 | All versions | 0:2.5.5-1.el7ae |
| `ansible-doc` | Red Hat:ansible_engine:2.5::el7 | All versions | 0:2.5.5-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.5.5-1.el7ae |
| `ansible-doc` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.5.5-1.el7ae |
| `ansible` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:2.4.5.0-1.el7ae |
| `ansible-doc` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:2.4.5.0-1.el7ae |
| `ansible-tower` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.5-1.el7at |
| `ansible-tower-server` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.5-1.el7at |
| `ansible-tower-setup` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.5-1.el7at |
| `ansible-tower-ui` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.5-1.el7at |
| `ansible-tower-venv-ansible` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.5-1.el7at |
| `ansible-tower-venv-tower` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:3.2.5-1.el7at |
| `cfme` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-amazon-smartstate` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-appliance` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-appliance-common` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-appliance-debuginfo` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-appliance-tools` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-debuginfo` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-gemset` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `cfme-gemset-debuginfo` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:5.9.3.4-1.el7cf |
| `httpd-configmap-generator` | Red Hat:cloudforms_managementengine:5.9::el7 | All versions | 0:0.2.2-1.1.el7cf |
| `imgbased` | Red Hat:enterprise_linux:7::hypervisor | All versions | 0:1.0.20-0.1.el7ev |
| `python-imgbased` | Red Hat:enterprise_linux:7::hypervisor | All versions | 0:1.0.20-0.1.el7ev |
| `redhat-release-virtualization-host` | Red Hat:enterprise_linux:7::hypervisor | All versions | 0:4.2-4.3.el7 |
| `redhat-virtualization-host` | Red Hat:enterprise_linux:7::hypervisor | All versions | 0:4.2-20180622.0.el7_5 |
| `redhat-virtualization-host-image-update` | Red Hat:enterprise_linux:7::hypervisor | All versions | 0:4.2-20180622.0.el7_5 |
| `redhat-virtualization-host-image-update-placeholder` | Red Hat:enterprise_linux:7::hypervisor | All versions | 0:4.2-4.3.el7 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Redhat Ansible Engine, Redhat Cloudforms, Redhat Openstack, Redhat Virtualization.

## How do I fix CVE-2018-10855?

Upgrade ansible to a fixed version for your release line: 2.4.5.0 or 2.5.5.

## Is CVE-2018-10855 being exploited?

There is no known exploitation of CVE-2018-10855 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10855 and fix it if it is affected.

What it is: CVE-2018-10855 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 2 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-10855 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.4.0.0; fixed in 2.4.5.0
- ansible (PyPI): affected from 2.4.0.0; fixed in 2.4.5.0
- ansible (PyPI): affected from 2.5; fixed in 2.5.5, 2.4.5.0
- ansible (PyPI): affected from 2.5.0a1; fixed in 2.5.5
- ansible (PyPI): affected from 2.5.0a1; fixed in 2.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10855/ (Markdown: https://insights.sbomify.com/CVE-2018-10855/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10855
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10855
- OSV: https://osv.dev/vulnerability/CVE-2018-10855

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10855/
Summaries are generated and may contain mistakes; the official description above is the record.
