# CVE-2018-10856: Podman Elevated Container Privileges

> Podman fails to drop capabilities for non-root containers, granting unnecessary privileges that could lead to privilege escalation.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wp7w-vx86-vj9h, GO-2023-1962, RHSA-2018:2037

## What is CVE-2018-10856?

CVE-2018-10856 is a medium-severity vulnerability in [UNKNOWN] podman, published on 2 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

It has been discovered that podman before version 0.6.1 does not drop capabilities when executing a container as a non-root user. This results in unnecessary privileges being granted to the container.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-250 (Execution with Unnecessary Privileges)

## Which versions are affected by CVE-2018-10856?

6 open source packages ship an affected version, including github.com/containers/podman, github.com/containers/podman/v2 and github.com/containers/podman/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containers/podman` | Go | All versions | 0.6.1 |
| `github.com/containers/podman` | Go | All versions | 0.6.1 |
| `github.com/containers/podman` | Go | All versions | 0.6.1 |
| `github.com/containers/podman/v2` | Go | All versions | None |
| `github.com/containers/podman/v3` | Go | All versions | None |
| `github.com/containers/podman/v4` | Go | All versions | None |
| `podman` | Red Hat:rhel_extras_other:7 | All versions | 0:0.6.1-3.git3e0ff12.el7 |
| `podman-debuginfo` | Red Hat:rhel_extras_other:7 | All versions | 0:0.6.1-3.git3e0ff12.el7 |

Products: Libpod Project Libpod.

## How do I fix CVE-2018-10856?

Upgrade github.com/containers/podman to 0.6.1 or later.

## Is CVE-2018-10856 being exploited?

There is no known exploitation of CVE-2018-10856 in the wild and no public exploit code.

## Other vulnerabilities in [UNKNOWN] podman

- [CVE-2019-10152](https://insights.sbomify.com/CVE-2019-10152/): Podman Path Traversal Vulnerability leads to arbitrary file read/write (high 7.5)
- [CVE-2020-1726](https://insights.sbomify.com/CVE-2020-1726/): Podman has Files or Directories Accessible to External Parties (medium 5.9)
- [CVE-2019-18466](https://insights.sbomify.com/CVE-2019-18466/): Podman Symlink Vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10856 and fix it if it is affected.

What it is: CVE-2018-10856 is a medium-severity vulnerability in [UNKNOWN] podman, published on 2 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-10856 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containers/podman (Go): affected all versions; fixed in 0.6.1
- github.com/containers/podman (Go): affected all versions; fixed in 0.6.1
- github.com/containers/podman (Go): affected all versions; fixed in 0.6.1
- github.com/containers/podman/v2 (Go): affected all versions; no fix listed
- github.com/containers/podman/v3 (Go): affected all versions; no fix listed
- github.com/containers/podman/v4 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10856/ (Markdown: https://insights.sbomify.com/CVE-2018-10856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10856
- OSV: https://osv.dev/vulnerability/CVE-2018-10856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10856/
Summaries are generated and may contain mistakes; the official description above is the record.
