{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2018-1086 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-1086 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1086 and fix it if it is affected.\n\nWhat it is: CVE-2018-1086 is a medium-severity vulnerability in Debian Debian Linux, published on 12 Apr 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1086 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1086/ (Markdown: https://insights.sbomify.com/CVE-2018-1086/index.md)","id":"CVE-2018-1086","markdown":"https://insights.sbomify.com/CVE-2018-1086/index.md","name":"CVE-2018-1086","record":{"aliases":["DEBIAN-CVE-2018-1086","DSA-4169-1","GHSA-p9pc-vgv7-x9j9","RHSA-2018:1927","UBUNTU-CVE-2018-1086"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Pacemaker cluster suite","requires_auth":"low_privilege","summary":"A remote attacker with a valid token can bypass debug parameter removal in the pcsd REST interface to disclose sensitive information and potentially elevate privileges.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pacemaker_command_line_interface","vendor":"clusterlabs"},{"product":"debian_linux","vendor":"debian"},{"product":"enterprise_linux_server_eus","vendor":"redhat"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"pcs before versions 0.9.164 and 0.10 is vulnerable to a debug parameter removal bypass. REST interface of the pcsd service did not properly remove the pcs debug argument from the /run_pcs query, possibly disclosing sensitive information. A remote attacker with a valid token could use this flaw to elevate their privilege.","ecosystems":["Red Hat:enterprise_linux:6::server"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in pcs","id":"CVE-2018-1086","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux","redhat:enterprise_linux_server_eus"],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"Privilege escalation in KVM","id":"CVE-2018-1087"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["0:0.9.155-3.el6"],"introduced":["0"],"last_affected":[],"package":"pcs","purl":"pkg:rpm/redhat/pcs","source":"RHSA-2018:1927"},{"ecosystem":"Red Hat:enterprise_linux:6::server","fixed":["0:0.9.155-3.el6"],"introduced":["0"],"last_affected":[],"package":"pcs-debuginfo","purl":"pkg:rpm/redhat/pcs-debuginfo","source":"RHSA-2018:1927"}],"prev":{"headline":"Misconfiguration in openshift-ansible","id":"CVE-2018-1085"},"products":["pcs"],"published":"2018-04-12","related":[{"cvss_score":8.7,"headline":"Path traversal in pcs","id":"CVE-2018-1079","kev_date_added":null,"published":"2018-04-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["redhat"]},"summary":"A remote attacker with a valid token can bypass debug parameter removal in the pcsd REST interface to disclose sensitive information and potentially elevate privileges.","url":"https://insights.sbomify.com/CVE-2018-1086/"}