CVE-2018-10889 Moodle sensitive information disclosure
Moodle's data privacy export feature failed to omit logs, potentially exposing details of other users who interacted with the requester.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-10889?
CVE-2018-10889 is a medium-severity vulnerability in Moodle Moodle, published on 10 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7. No option existed to omit logs from data privacy exports, which may contain details of other users who interacted with the requester.
Weakness: CWE-532
Which versions are affected by CVE-2018-10889?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.3 | 3.3.7 |
moodle/moodle Packagist | From 3.3 | 3.3.7 |
moodle/moodle Packagist | From 3.4.3 | 3.4.4 |
moodle/moodle Packagist | From 3.4.3 | 3.4.4 |
moodle/moodle Packagist | From 3.5 | 3.5.1 |
moodle/moodle Packagist | From 3.5 | 3.5.1 |
Products include Moodle Moodle.
How do I fix CVE-2018-10889?
Upgrade moodle/moodle to a fixed version for your release line: 3.3.7, 3.4.4 or 3.5.1.
Is CVE-2018-10889 being exploited?
There is no known exploitation of CVE-2018-10889 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-wmvq-q9h8-7j4g, UBUNTU-CVE-2018-10889.