CVE-2018-10890 Moodle Exposure of Sensitive Information to an Unauthorized Actor

Medium 4.3 Published Updated

Attackers can retrieve hidden course categories via the core_course_get_categories web service, exposing unauthorized data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-10890?

CVE-2018-10890 is a medium-severity vulnerability in Moodle Moodle, published on 10 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. It was possible for the core_course_get_categories web service to return hidden categories, which should be omitted when fetching course categories.

Weakness: CWE-200

Which versions are affected by CVE-2018-10890?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.13.1.13
moodle/moodle PackagistFrom 3.13.1.13
moodle/moodle PackagistFrom 3.33.3.7
moodle/moodle PackagistFrom 3.33.3.7
moodle/moodle PackagistFrom 3.43.4.4
moodle/moodle PackagistFrom 3.43.4.4
2 more packages
moodle/moodle PackagistFrom 3.53.5.1
moodle/moodle PackagistFrom 3.53.5.1

Products include Moodle Moodle.

How do I fix CVE-2018-10890?

Upgrade moodle/moodle to a fixed version for your release line: 3.1.13, 3.3.7, 3.4.4 or 3.5.1.

Is CVE-2018-10890 being exploited?

There is no known exploitation of CVE-2018-10890 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-5w4h-xrr5-7273, UBUNTU-CVE-2018-10890.

Is CVE-2018-10890 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free