CVE-2018-10891 Moodle XSS Vulnerability
Attackers can execute arbitrary JavaScript via malicious quiz question imports, potentially leading to session hijacking or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-10891?
CVE-2018-10891 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 10 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.
Weakness: CWE-20
Which versions are affected by CVE-2018-10891?
10 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1.0 | 3.1.13 |
moodle/moodle Packagist | From 3.1.0 | 3.1.13 |
moodle/moodle Packagist | From 3.2.0 | 3.2.10 |
moodle/moodle Packagist | From 3.2.0 | 3.2.10 |
moodle/moodle Packagist | From 3.3.0 | 3.3.7 |
moodle/moodle Packagist | From 3.3.0 | 3.3.7 |
4 more packages
moodle/moodle Packagist | From 3.4.0 | 3.4.4 |
moodle/moodle Packagist | From 3.4.0 | 3.4.4 |
moodle/moodle Packagist | From 3.5.0 | 3.5.1 |
moodle/moodle Packagist | From 3.5.0 | 3.5.1 |
Products include Moodle Moodle.
How do I fix CVE-2018-10891?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.13, 3.2.10, 3.3.7 or 3.4.4.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-10891 being exploited?
There is no known exploitation of CVE-2018-10891 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-p7v9-gjrh-563x, UBUNTU-CVE-2018-10891.