# CVE-2018-10894: Keycloak Authentication Error

> Attackers can bypass SAML authentication using expired certificates to access unauthorized data in Keycloak.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xvv8-8wh9-9fh2

## What is CVE-2018-10894?

CVE-2018-10894 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

It was found that SAML authentication in Keycloak 3.4.3.Final incorrectly authenticated expired certificates. A malicious user could use this to access unauthorized data or possibly conduct further attacks.

Weakness: CWE-295 (Improper Certificate Validation), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2018-10894?

4 open source packages ship an affected version, including org.keycloak:keycloak-saml-adapter-core and org.keycloak:keycloak-services. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-saml-adapter-core` | Maven | All versions | 4.4.0.Final |
| `org.keycloak:keycloak-saml-adapter-core` | Maven | All versions | 4.4.0.Final |
| `org.keycloak:keycloak-services` | Maven | All versions | 4.4.0.Final |
| `org.keycloak:keycloak-services` | Maven | All versions | 4.4.0.Final |

Products: Redhat Keycloak, Redhat Single Sign-On.

## How do I fix CVE-2018-10894?

Upgrade org.keycloak:keycloak-saml-adapter-core to 4.4.0.Final or later.

## Is CVE-2018-10894 being exploited?

There is no known exploitation of CVE-2018-10894 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10894 and fix it if it is affected.

What it is: CVE-2018-10894 is a medium-severity authentication bypass vulnerability in Redhat Keycloak, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-10894 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-saml-adapter-core (Maven): affected all versions; fixed in 4.4.0.Final
- org.keycloak:keycloak-saml-adapter-core (Maven): affected all versions; fixed in 4.4.0.Final
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 4.4.0.Final
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 4.4.0.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10894/ (Markdown: https://insights.sbomify.com/CVE-2018-10894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10894
- OSV: https://osv.dev/vulnerability/CVE-2018-10894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10894/
Summaries are generated and may contain mistakes; the official description above is the record.
