{"answers":{"affected":"3 open source packages ship an affected version, including qutebrowser. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-10895 in the wild and no public exploit code.","fix":"Upgrade qutebrowser to 1.4.1 or later.","what":"CVE-2018-10895 is a critical vulnerability in qutebrowser cross-site request forgery flaw allows sites to access 'qute, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-10895 and fix it if it is affected.\n\nWhat it is: CVE-2018-10895 is a critical vulnerability in qutebrowser cross-site request forgery flaw allows sites to access 'qute, published on 12 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-10895 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- qutebrowser (PyPI): affected all versions; fixed in 1.4.1\n- qutebrowser (PyPI): affected all versions; fixed in 1.4.1\n- qutebrowser (PyPI): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10895/ (Markdown: https://insights.sbomify.com/CVE-2018-10895/index.md)","id":"CVE-2018-10895","markdown":"https://insights.sbomify.com/CVE-2018-10895/index.md","name":"CVE-2018-10895","record":{"aliases":["DEBIAN-CVE-2018-10895","GHSA-wgmx-52ph-qqcw","PYSEC-2018-27","UBUNTU-CVE-2018-10895"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"qutebrowser web browser","requires_auth":"none","summary":"A CSRF flaw in qutebrowser allows malicious websites to modify settings and execute arbitrary code via bash scripts.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"qutebrowser","vendor":"qutebrowser"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Qutebrowser CSRF Vulnerability","id":"CVE-2018-10895","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"csrf","year":"2018"},"n_packages":3,"n_references":3,"next":{"headline":"Misconfiguration in cloud-init","id":"CVE-2018-10896"},"packages":[{"ecosystem":"PyPI","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"qutebrowser","purl":null,"source":"GHSA-wgmx-52ph-qqcw"},{"ecosystem":"PyPI","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"qutebrowser","purl":"pkg:pypi/qutebrowser","source":"GHSA-wgmx-52ph-qqcw"},{"ecosystem":"PyPI","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"qutebrowser","purl":"pkg:pypi/qutebrowser","source":"PYSEC-2018-27"}],"prev":{"headline":"Keycloak Authentication Error","id":"CVE-2018-10894"},"products":["cross-site request forgery flaw allows sites to access 'qute"],"published":"2018-07-12","related":[{"cvss_score":8.8,"headline":"Arbitrary command execution on Windows in qutebrowser","id":"CVE-2021-41146","kev_date_added":null,"published":"2021-10-21"},{"cvss_score":6.1,"headline":"Qutebrowser XSS Vulnerability","id":"CVE-2018-1000559","kev_date_added":null,"published":"2018-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["qutebrowser"]},"summary":"A CSRF flaw in qutebrowser allows malicious websites to modify settings and execute arbitrary code via bash scripts.","url":"https://insights.sbomify.com/CVE-2018-10895/"}