CVE-2018-10898 Hardcoded credentials in openstack-tripleo-heat-templates

High 8.8 Published Updated

OpenStack TripleO Heat Templates use easily guessable default credentials for Opendaylight, allowing attackers to bypass authentication and take over accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2018-10898?

CVE-2018-10898 is a high-severity vulnerability in Redhat Openstack, published on 30 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability was found in openstack-tripleo-heat-templates before version 8.0.2-40. When deployed using Director using default configuration, Opendaylight in RHOSP13 is configured with easily guessable default credentials.

Weakness: CWE-798

Which versions are affected by CVE-2018-10898?

1 open source package ship an affected version, including tripleo-heat-templates. It affects 2 products.

PackageAffectedFixed in
tripleo-heat-templates PyPIAll versions8.0.3
Linux distribution packages (7)
openstack-tripleo-common Red Hat:openstack:13::el7All versions0:8.6.1-23.el7ost
openstack-tripleo-common-container-base Red Hat:openstack:13::el7All versions0:8.6.1-23.el7ost
openstack-tripleo-common-containers Red Hat:openstack:13::el7All versions0:8.6.1-23.el7ost
openstack-tripleo-common-devtools Red Hat:openstack:13::el7All versions0:8.6.1-23.el7ost
openstack-tripleo-heat-templates Red Hat:openstack:13::el7All versions0:8.0.2-43.el7ost
puppet-opendaylight Red Hat:openstack:13::el7All versions0:8.1.2-2.38977efgit.el7ost
python-tripleoclient Red Hat:openstack:13::el7All versions0:9.2.1-13.el7ost

Products include Openstack Tripleo Heat Templates, Redhat Openstack.

How do I fix CVE-2018-10898?

Upgrade tripleo-heat-templates to 8.0.3 or later.

Is CVE-2018-10898 being exploited?

There is no known exploitation of CVE-2018-10898 in the wild and no public exploit code.

All Redhat Openstack vulnerabilities

Sources

Also known as GHSA-9xj4-8jr9-rf9f, PYSEC-2018-102, RHSA-2018:2214, UBUNTU-CVE-2018-10898.

Is CVE-2018-10898 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free