# CVE-2018-10898: Hardcoded credentials in openstack-tripleo-heat-templates

> OpenStack TripleO Heat Templates use easily guessable default credentials for Opendaylight, allowing attackers to bypass authentication and take over accounts.

- **Severity:** High 8.8 (`CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-9xj4-8jr9-rf9f, PYSEC-2018-102, RHSA-2018:2214, UBUNTU-CVE-2018-10898

## What is CVE-2018-10898?

CVE-2018-10898 is a high-severity vulnerability in Redhat Openstack, published on 30 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was found in openstack-tripleo-heat-templates before version 8.0.2-40. When deployed using Director using default configuration, Opendaylight in RHOSP13 is configured with easily guessable default credentials.

Weakness: CWE-798 (Use of Hard-coded Credentials)

## Which versions are affected by CVE-2018-10898?

1 open source package ship an affected version, including tripleo-heat-templates. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tripleo-heat-templates` | PyPI | All versions | 8.0.3 |
| `openstack-tripleo-common` | Red Hat:openstack:13::el7 | All versions | 0:8.6.1-23.el7ost |
| `openstack-tripleo-common-container-base` | Red Hat:openstack:13::el7 | All versions | 0:8.6.1-23.el7ost |
| `openstack-tripleo-common-containers` | Red Hat:openstack:13::el7 | All versions | 0:8.6.1-23.el7ost |
| `openstack-tripleo-common-devtools` | Red Hat:openstack:13::el7 | All versions | 0:8.6.1-23.el7ost |
| `openstack-tripleo-heat-templates` | Red Hat:openstack:13::el7 | All versions | 0:8.0.2-43.el7ost |
| `puppet-opendaylight` | Red Hat:openstack:13::el7 | All versions | 0:8.1.2-2.38977efgit.el7ost |
| `python-tripleoclient` | Red Hat:openstack:13::el7 | All versions | 0:9.2.1-13.el7ost |

Products: Openstack Tripleo Heat Templates, Redhat Openstack.

## How do I fix CVE-2018-10898?

Upgrade tripleo-heat-templates to 8.0.3 or later.

## Is CVE-2018-10898 being exploited?

There is no known exploitation of CVE-2018-10898 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openstack

- [CVE-2015-5271](https://insights.sbomify.com/CVE-2015-5271/): TripleO Heat templates might allow remote attackers to obtain sensitive information from private containers (high 7.5)
- [CVE-2015-5303](https://insights.sbomify.com/CVE-2015-5303/): OpenStack TripleO Heat templates spoof metadata requests (high 7.5)
- [CVE-2021-3585](https://insights.sbomify.com/CVE-2021-3585/): Information disclosure in openstack/tripleo-heat-templates. (medium 5.5)
- [CVE-2021-4180](https://insights.sbomify.com/CVE-2021-4180/): Exposure of Sensitive Information to an Unauthorized Actor in OpenStack tripleo-heat-templates (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10898 and fix it if it is affected.

What it is: CVE-2018-10898 is a high-severity vulnerability in Redhat Openstack, published on 30 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-10898 in the wild and no public exploit code.

Affected packages and fixed versions:
- tripleo-heat-templates (PyPI): affected all versions; fixed in 8.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10898/ (Markdown: https://insights.sbomify.com/CVE-2018-10898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10898
- OSV: https://osv.dev/vulnerability/CVE-2018-10898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10898/
Summaries are generated and may contain mistakes; the official description above is the record.
