{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-10900 exists.","fix":"Apply the vendor's patch.","what":"CVE-2018-10900 is a high-severity command injection vulnerability in Debian Debian Linux, published on 26 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-10900 and fix it if it is affected.\n\nWhat it is: CVE-2018-10900 is a high-severity command injection vulnerability in Debian Debian Linux, published on 26 Jul 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-10900 exists.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10900/ (Markdown: https://insights.sbomify.com/CVE-2018-10900/index.md)","id":"CVE-2018-10900","markdown":"https://insights.sbomify.com/CVE-2018-10900/index.md","name":"CVE-2018-10900","record":{"aliases":["DEBIAN-CVE-2018-10900","DLA-1454-1","DSA-4253-1","GHSA-6cmp-3578-qc4p","SUSE-SU-2018:2297-1","UBUNTU-CVE-2018-10900","openSUSE-SU-2024:10604-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"NetworkManager VPNC plugin","requires_auth":"low_privilege","summary":"An attacker can inject a password helper parameter to execute arbitrary commands as root via the NetworkManager VPNC plugin.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"network_manager_vpnc","vendor":"gnome"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6 is vulnerable to a privilege escalation attack. A new line character can be used to inject a Password helper parameter into the configuration data passed to VPNC, allowing an attacker to execute arbitrary commands as root.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Workstation Extension 12 SP3"],"exploits":{"exploitdb":2,"first_seen":"2018-07-26","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2018-07-26","kind":"metasploit","ref":"exploit/linux/local/network_manager_vpnc_username_priv_esc","stars":null,"title":"Network Manager VPNC Username Privilege Escalation"},{"date":"2018-08-31","kind":"exploitdb","ref":"45313","stars":null,"title":"Network Manager VPNC 1.2.6 - 'Username' Local Privilege Escalation (Metasploit)"},{"date":"2018-08-31","kind":"exploitdb","ref":"45313","stars":null,"title":"Network Manager VPNC 1.2.6 - 'Username' Local Privilege Escalation (Metasploit)"}],"tier":"weaponised"},"has_fix":true,"headline":"Command injection in networkmanager-vpnc","id":"CVE-2018-10900","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"command_injection","year":"2018"},"n_packages":2,"n_references":9,"next":{"headline":"Privilege escalation in kernel:","id":"CVE-2018-10901"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["1.0.8-8.4.2"],"introduced":["0"],"last_affected":[],"package":"NetworkManager-vpnc","purl":"pkg:rpm/suse/NetworkManager-vpnc\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:2297-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP3","fixed":["1.0.8-8.4.2"],"introduced":["0"],"last_affected":[],"package":"NetworkManager-vpnc","purl":"pkg:rpm/suse/NetworkManager-vpnc\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP3","source":"SUSE-SU-2018:2297-1"}],"prev":{"headline":"Cross-Site Request Forgery in Jolokia","id":"CVE-2018-10899"},"products":["networkmanager-vpnc"],"published":"2018-07-26","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["[UNKNOWN]"]},"summary":"An attacker can inject a password helper parameter to execute arbitrary commands as root via the NetworkManager VPNC plugin.","url":"https://insights.sbomify.com/CVE-2018-10900/"}