{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-10931 in the wild and no public exploit code.","fix":"Upgrade cobbler to 3.0.0 or later.","what":"CVE-2018-10931 is a critical missing authorization vulnerability in Redhat Satellite, published on 9 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-10931 and fix it if it is affected.\n\nWhat it is: CVE-2018-10931 is a critical missing authorization vulnerability in Redhat Satellite, published on 9 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-10931 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected from 2.6.0; fixed in 3.0.0\n- cobbler (PyPI): affected from 2.6.0; fixed in 3.0.0\n- cobbler (PyPI): affected from 2.6.0; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10931/ (Markdown: https://insights.sbomify.com/CVE-2018-10931/index.md)","id":"CVE-2018-10931","markdown":"https://insights.sbomify.com/CVE-2018-10931/index.md","name":"CVE-2018-10931","record":{"aliases":["GHSA-8787-63px-3m23","PYSEC-2026-313","RHSA-2018:2372","SUSE-SU-2018:2550-1","UBUNTU-CVE-2018-10931"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"none","summary":"Unauthenticated attackers can access all XMLRPC functions to gain high privileges and upload files to arbitrary locations on the Cobbler server.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cobbler","vendor":"cobbler_project"},{"product":"satellite","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-749","name":"Exposed Dangerous Method or Function"}],"description":"It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.","ecosystems":["PyPI","Red Hat:network_satellite:5.6::el6","Red Hat:network_satellite:5.7::el6","Red Hat:network_satellite:5.8::el6","SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS","SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler has Exposed Dangerous Method or Function","id":"CVE-2018-10931","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:satellite","products":["redhat:satellite"],"type":"missing_authorization","year":"2018"},"n_packages":8,"n_references":4,"next":{"headline":"Command injection in lldptool","id":"CVE-2018-10932"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["2.6.0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-8787-63px-3m23"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["2.6.0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-8787-63px-3m23"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["2.6.0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-313"},{"ecosystem":"Red Hat:network_satellite:5.6::el6","fixed":["0:2.0.7-44.1.el6sat"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/redhat/cobbler","source":"RHSA-2018:2372"},{"ecosystem":"Red Hat:network_satellite:5.7::el6","fixed":["0:2.0.7-68.1.el6sat"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/redhat/cobbler","source":"RHSA-2018:2372"},{"ecosystem":"Red Hat:network_satellite:5.8::el6","fixed":["0:2.0.7-73.el6sat"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/redhat/cobbler","source":"RHSA-2018:2372"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS","fixed":["2.2.2-0.68.6.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP3-CLIENT-TOOLS","source":"SUSE-SU-2018:2550-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS","fixed":["2.2.2-0.68.6.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4-CLIENT-TOOLS","source":"SUSE-SU-2018:2550-1"}],"prev":{"headline":"Path traversal in glusterfs","id":"CVE-2018-10930"},"products":["cobbler"],"published":"2018-08-09","related":[{"cvss_score":9.8,"headline":"Cobbler before 3.3.0 allows log poisoning","id":"CVE-2021-40323","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":9.8,"headline":"Cobbler vulnerable to arbitrary code execution","id":"CVE-2017-1000469","kev_date_added":null,"published":"2018-01-03"},{"cvss_score":8.2,"headline":"Improper Authorization in cobbler/cobbler","id":"CVE-2022-0860","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":7.8,"headline":"Command Injection in Cobbler","id":"CVE-2021-45082","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","id":"CVE-2021-40325","kev_date_added":null,"published":"2021-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["The Cobbler Project"]},"summary":"Unauthenticated attackers can access all XMLRPC functions to gain high privileges and upload files to arbitrary locations on the Cobbler server.","url":"https://insights.sbomify.com/CVE-2018-10931/"}