# CVE-2018-10931: Cobbler has Exposed Dangerous Method or Function

> Unauthenticated attackers can access all XMLRPC functions to gain high privileges and upload files to arbitrary locations on the Cobbler server.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8787-63px-3m23, PYSEC-2026-313, RHSA-2018:2372, SUSE-SU-2018:2550-1, UBUNTU-CVE-2018-10931

## What is CVE-2018-10931?

CVE-2018-10931 is a critical missing authorization vulnerability in Redhat Satellite, published on 9 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.

Weakness: CWE-749 (Exposed Dangerous Method or Function)

## Which versions are affected by CVE-2018-10931?

3 open source packages ship an affected version, including cobbler. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | From 2.6.0 | 3.0.0 |
| `cobbler` | PyPI | From 2.6.0 | 3.0.0 |
| `cobbler` | PyPI | From 2.6.0 | 3.0.0 |
| `cobbler` | Red Hat:network_satellite:5.6::el6 | All versions | 0:2.0.7-44.1.el6sat |
| `cobbler` | Red Hat:network_satellite:5.7::el6 | All versions | 0:2.0.7-68.1.el6sat |
| `cobbler` | Red Hat:network_satellite:5.8::el6 | All versions | 0:2.0.7-73.el6sat |
| `cobbler` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 2.2.2-0.68.6.1 |
| `cobbler` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 2.2.2-0.68.6.1 |

Products: Cobbler Project Cobbler, Redhat Satellite.

## How do I fix CVE-2018-10931?

Upgrade cobbler to 3.0.0 or later.

## Is CVE-2018-10931 being exploited?

There is no known exploitation of CVE-2018-10931 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Satellite

- [CVE-2021-40323](https://insights.sbomify.com/CVE-2021-40323/): Cobbler before 3.3.0 allows log poisoning (critical 9.8)
- [CVE-2017-1000469](https://insights.sbomify.com/CVE-2017-1000469/): Cobbler vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2022-0860](https://insights.sbomify.com/CVE-2022-0860/): Improper Authorization in cobbler/cobbler (high 8.2)
- [CVE-2021-45082](https://insights.sbomify.com/CVE-2021-45082/): Command Injection in Cobbler (high 7.8)
- [CVE-2021-40324](https://insights.sbomify.com/CVE-2021-40324/): Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10931 and fix it if it is affected.

What it is: CVE-2018-10931 is a critical missing authorization vulnerability in Redhat Satellite, published on 9 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-10931 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected from 2.6.0; fixed in 3.0.0
- cobbler (PyPI): affected from 2.6.0; fixed in 3.0.0
- cobbler (PyPI): affected from 2.6.0; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10931/ (Markdown: https://insights.sbomify.com/CVE-2018-10931/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10931
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10931
- OSV: https://osv.dev/vulnerability/CVE-2018-10931

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10931/
Summaries are generated and may contain mistakes; the official description above is the record.
