CVE-2018-11039 Spring Framework Cross Site Tracing (XST)
Attackers can escalate existing XSS vulnerabilities to Cross Site Tracing attacks if HiddenHttpMethodFilter is enabled in Spring MVC applications.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-11039?
CVE-2018-11039 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 25 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Spring Framework (versions 5.0.x prior to 5.0.7, versions 4.3.x prior to 4.3.18, and older unsupported versions) allow web applications to change the HTTP request method to any HTTP method (including TRACE) using the HiddenHttpMethodFilter in Spring MVC. If an application has a pre-existing XSS vulnerability, a malicious user (or attacker) can use this filter to escalate to an XST (Cross Site Tracing) attack.
Which versions are affected by CVE-2018-11039?
4 open source packages ship an affected version, including org.springframework:spring-web. It affects 33 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework:spring-web Maven | From 4.3.0 | 4.3.18 |
org.springframework:spring-web Maven | From 4.3.0 | 4.3.18 |
org.springframework:spring-web Maven | From 5.0.0 | 5.0.7 |
org.springframework:spring-web Maven | From 5.0.0 | 5.0.7 |
Products include Debian Debian Linux, Oracle Agile Product Lifecycle Management, Oracle Application Testing Suite, Oracle Communications Diameter Signaling Router, Oracle Communications Network Integrity, Oracle Communications Online Mediation Controller and 27 more.
How do I fix CVE-2018-11039?
Upgrade org.springframework:spring-web to a fixed version for your release line: 4.3.18 or 5.0.7.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-11039 being exploited?
There is no known exploitation of CVE-2018-11039 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-11039, GHSA-9gcm-f4x3-8jpw, UBUNTU-CVE-2018-11039.