# CVE-2018-11040: Moderate severity vulnerability that affects org.springframework:spring-core

> Spring Framework allows cross-domain requests via JSONP when configured, potentially bypassing same-origin policy restrictions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2018
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2018-11040, GHSA-f26x-pr96-vw86, UBUNTU-CVE-2018-11040

## What is CVE-2018-11040?

CVE-2018-11040 is a high-severity vulnerability in Debian Debian Linux, published on 25 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Spring Framework, versions 5.0.x prior to 5.0.7 and 4.3.x prior to 4.3.18 and older unsupported versions, allows web applications to enable cross-domain requests via JSONP (JSON with Padding) through AbstractJsonpResponseBodyAdvice for REST controllers and MappingJackson2JsonView for browser requests. Both are not enabled by default in Spring Framework nor Spring Boot, however, when MappingJackson2JsonView is configured in an application, JSONP support is automatically ready to use through the "jsonp" and "callback" JSONP parameters, enabling cross-domain requests.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2018-11040?

4 open source packages ship an affected version, including org.springframework:spring-core. It affects 28 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | From 4.3.0.RELEASE | 4.3.18.RELEASE |
| `org.springframework:spring-core` | Maven | From 4.3.0.RELEASE | 4.3.18.RELEASE |
| `org.springframework:spring-core` | Maven | From 5.0.0.RELEASE | 5.0.7.RELEASE |
| `org.springframework:spring-core` | Maven | From 5.0.0.RELEASE | 5.0.7.RELEASE |

Products: Debian Debian Linux, Oracle Agile Product Lifecycle Management, Oracle Application Testing Suite, Oracle Communications Network Integrity, Oracle Communications Online Mediation Controller, Oracle Communications Services Gatekeeper, Oracle Communications Unified Inventory Management, Oracle Endeca Information Discovery Integrator, Oracle Enterprise Manager, Oracle Enterprise Manager Ops Center, Oracle Flexcube Private Banking, Oracle Healthcare Master Person Index, Oracle Hospitality Guest Access, Oracle Insurance Calculation Engine, Oracle Insurance Rules Palette, Oracle Micros Lucas, Oracle Mysql Enterprise Monitor, Oracle Product Lifecycle Management, Oracle Retail Advanced Inventory Planning, Oracle Retail Clearance Optimization Engine and 8 more.

## How do I fix CVE-2018-11040?

Upgrade org.springframework:spring-core to a fixed version for your release line: 4.3.18.RELEASE or 5.0.7.RELEASE.

## Is CVE-2018-11040 being exploited?

There is no known exploitation of CVE-2018-11040 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11040 and fix it if it is affected.

What it is: CVE-2018-11040 is a high-severity vulnerability in Debian Debian Linux, published on 25 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11040 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected from 4.3.0.RELEASE; fixed in 4.3.18.RELEASE
- org.springframework:spring-core (Maven): affected from 4.3.0.RELEASE; fixed in 4.3.18.RELEASE
- org.springframework:spring-core (Maven): affected from 5.0.0.RELEASE; fixed in 5.0.7.RELEASE
- org.springframework:spring-core (Maven): affected from 5.0.0.RELEASE; fixed in 5.0.7.RELEASE

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11040/ (Markdown: https://insights.sbomify.com/CVE-2018-11040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11040
- OSV: https://osv.dev/vulnerability/CVE-2018-11040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11040/
Summaries are generated and may contain mistakes; the official description above is the record.
