CVE-2018-11041 Cloud Foundry UAA open redirect
Attackers can redirect users to malicious sites after login due to unvalidated redirect URLs in Cloud Foundry UAA.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-11041?
CVE-2018-11041 is a medium-severity vulnerability in Cloud Foundry UAA, published on 25 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cloud Foundry UAA, versions later than 4.6.0 and prior to 4.19.0 except 4.10.1 and 4.7.5 and uaa-release versions later than v48 and prior to v60 except v55.1 and v52.9, does not validate redirect URL values on a form parameter used for internal UAA redirects on the login page, allowing open redirects. A remote attacker can craft a malicious link that, when clicked, will redirect users to arbitrary websites after a successful login attempt.
Weakness: CWE-601
Which versions are affected by CVE-2018-11041?
8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 4.7.5 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | All versions | 4.7.5 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.11.0 | 4.12.3 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.11.0 | 4.12.3 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.13.0 | 4.19.0 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.13.0 | 4.19.0 |
2 more packages
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.8.0 | 4.10.1 |
org.cloudfoundry.identity:cloudfoundry-identity-server Maven | From 4.8.0 | 4.10.1 |
Products include Pivotal Software Cloud Foundry Uaa, Pivotal Software Cloud Foundry Uaa-Release.
How do I fix CVE-2018-11041?
Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 4.7.5, 4.12.3, 4.19.0 or 4.10.1.
Is CVE-2018-11041 being exploited?
There is no known exploitation of CVE-2018-11041 in the wild and no public exploit code.
Other vulnerabilities in Cloud Foundry UAA
Sources
Also known as GHSA-xh4m-99qp-w483.