# CVE-2018-11041: Cloud Foundry UAA open redirect

> Attackers can redirect users to malicious sites after login due to unvalidated redirect URLs in Cloud Foundry UAA.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-xh4m-99qp-w483

## What is CVE-2018-11041?

CVE-2018-11041 is a medium-severity vulnerability in Cloud Foundry UAA, published on 25 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cloud Foundry UAA, versions later than 4.6.0 and prior to 4.19.0 except 4.10.1 and 4.7.5 and uaa-release versions later than v48 and prior to v60 except v55.1 and v52.9, does not validate redirect URL values on a form parameter used for internal UAA redirects on the login page, allowing open redirects. A remote attacker can craft a malicious link that, when clicked, will redirect users to arbitrary websites after a successful login attempt.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2018-11041?

8 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 4.7.5 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 4.7.5 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.11.0 | 4.12.3 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.11.0 | 4.12.3 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.13.0 | 4.19.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.13.0 | 4.19.0 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.8.0 | 4.10.1 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | From 4.8.0 | 4.10.1 |

Products: Pivotal Software Cloud Foundry Uaa, Pivotal Software Cloud Foundry Uaa-Release.

## How do I fix CVE-2018-11041?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to a fixed version for your release line: 4.7.5, 4.12.3, 4.19.0 or 4.10.1.

## Is CVE-2018-11041 being exploited?

There is no known exploitation of CVE-2018-11041 in the wild and no public exploit code.

## Other vulnerabilities in Cloud Foundry UAA

- [CVE-2018-15761](https://insights.sbomify.com/CVE-2018-15761/): UAA Privilege Escalation (critical 9.9)
- [CVE-2018-11047](https://insights.sbomify.com/CVE-2018-11047/): Cloud Foundry UAA accepts refresh token as access token on admin endpoints (high 7.5)
- [CVE-2019-3794](https://insights.sbomify.com/CVE-2019-3794/): UAA - Login app subject to clickjacking attack (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11041 and fix it if it is affected.

What it is: CVE-2018-11041 is a medium-severity vulnerability in Cloud Foundry UAA, published on 25 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-11041 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 4.7.5
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 4.7.5
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.11.0; fixed in 4.12.3
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.11.0; fixed in 4.12.3
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.13.0; fixed in 4.19.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.13.0; fixed in 4.19.0
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.8.0; fixed in 4.10.1
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected from 4.8.0; fixed in 4.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11041/ (Markdown: https://insights.sbomify.com/CVE-2018-11041/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11041
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11041
- OSV: https://osv.dev/vulnerability/CVE-2018-11041

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11041/
Summaries are generated and may contain mistakes; the official description above is the record.
