# CVE-2018-11065: SQL injection in RSA Archer

> A SQL injection vulnerability in the embedded WorkPoint component allows malicious users to read data from the back-end database.

- **Severity:** Low 2.7 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-m4p9-37xg-7wj9

## What is CVE-2018-11065?

CVE-2018-11065 is a low-severity SQL injection vulnerability in Dell EMC RSA Archer, published on 24 Aug 2018. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The WorkPoint component, which is embedded in all RSA Archer, versions 6.1.x, 6.2.x, 6.3.x prior to 6.3.0.7 and 6.4.x prior to 6.4.0.1, contains a SQL injection vulnerability. A malicious user could potentially exploit this vulnerability to execute SQL commands on the back-end database to read certain data. Embedded WorkPoint is upgraded to version 4.10.16, which contains a fix for the vulnerability.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2018-11065?

It affects 1 product.


Products: Rsa Archer.

## How do I fix CVE-2018-11065?

No fix has been published for CVE-2018-11065 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-11065 being exploited?

There is no known exploitation of CVE-2018-11065 in the wild and no public exploit code.

## Other vulnerabilities in Dell EMC RSA Archer

- [CVE-2022-30584](https://insights.sbomify.com/CVE-2022-30584/): Missing authorization in n/a (critical 9.6)
- [CVE-2020-5331](https://insights.sbomify.com/CVE-2020-5331/): Information disclosure in RSA Archer (high 8.8)
- [CVE-2018-11060](https://insights.sbomify.com/CVE-2018-11060/): Privilege escalation in RSA Archer (high 8.8)
- [CVE-2020-5334](https://insights.sbomify.com/CVE-2020-5334/): Cross-site scripting in RSA Archer (high 8.2)
- [CVE-2018-11059](https://insights.sbomify.com/CVE-2018-11059/): Cross-site scripting in RSA Archer (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11065 and fix it if it is affected.

What it is: CVE-2018-11065 is a low-severity SQL injection vulnerability in Dell EMC RSA Archer, published on 24 Aug 2018. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11065 in the wild and no public exploit code.

Affected product: Dell EMC RSA Archer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11065/ (Markdown: https://insights.sbomify.com/CVE-2018-11065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11065
- OSV: https://osv.dev/vulnerability/CVE-2018-11065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11065/
Summaries are generated and may contain mistakes; the official description above is the record.
