CVE-2018-11087 TLS validation error
Attackers can intercept and view data in transit due to missing hostname validation in TLS connections.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-11087?
CVE-2018-11087 is a medium-severity vulnerability in Pivotal Spring AMQP, published on 14 Sep 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Pivotal Spring AMQP, 1.x versions prior to 1.7.10 and 2.x versions prior to 2.0.6, expose a man-in-the-middle vulnerability due to lack of hostname validation. A malicious user that has the ability to intercept traffic would be able to view data in transit.
Weakness: CWE-295
Which versions are affected by CVE-2018-11087?
8 open source packages ship an affected version, including org.springframework.amqp:spring-amqp and com.rabbitmq:amqp-client. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.amqp:spring-amqp Maven | All versions | 1.7.10 |
org.springframework.amqp:spring-amqp Maven | All versions | 1.7.10 |
org.springframework.amqp:spring-amqp Maven | From 2.0.0 | 2.0.6 |
org.springframework.amqp:spring-amqp Maven | From 2.0.0 | 2.0.6 |
com.rabbitmq:amqp-client Maven | All versions | 4.8.0 |
com.rabbitmq:amqp-client Maven | All versions | 4.8.0 |
2 more packages
com.rabbitmq:amqp-client Maven | From 5.0.0 | 5.4.0 |
com.rabbitmq:amqp-client Maven | From 5.0.0 | 5.4.0 |
Products include Pivotal Software Spring Advanced Message Queuing Protocol, Vmware Rabbitmq Java Client.
How do I fix CVE-2018-11087?
Upgrade org.springframework.amqp:spring-amqp to a fixed version for your release line: 1.7.10 or 2.0.6.
Is CVE-2018-11087 being exploited?
There is no known exploitation of CVE-2018-11087 in the wild and no public exploit code.
Other vulnerabilities in Pivotal Spring AMQP
Sources
Also known as GHSA-w4g2-9hj6-5472.