CVE-2018-1109 Regular Expression Denial of Service (ReDoS) in braces

Medium 5.3 Published Updated

Attackers can cause denial of service in applications using the Braces library via Regular Expression Denial of Service attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1109?

CVE-2018-1109 is a medium-severity denial of service vulnerability in nodejs-braces, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was found in Braces versions 2.2.0 and above, prior to 2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.

Weakness: CWE-400, CWE-185

Which versions are affected by CVE-2018-1109?

2 open source packages ship an affected version, including braces. It affects 1 product.

PackageAffectedFixed in
braces npmFrom 2.2.02.3.1
braces npmFrom 2.2.02.3.1

Products include Braces Project Braces.

How do I fix CVE-2018-1109?

Upgrade braces to 2.3.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-1109 being exploited?

There is no known exploitation of CVE-2018-1109 in the wild and no public exploit code.

Sources

Also known as GHSA-cwfw-4gq5-mrqx.

Is CVE-2018-1109 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free