{"answers":{"affected":"2 open source packages ship an affected version, including braces. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1109 in the wild and no public exploit code.","fix":"Upgrade braces to 2.3.1 or later.","what":"CVE-2018-1109 is a medium-severity denial of service vulnerability in nodejs-braces, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1109 and fix it if it is affected.\n\nWhat it is: CVE-2018-1109 is a medium-severity denial of service vulnerability in nodejs-braces, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1109 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- braces (npm): affected from 2.2.0; fixed in 2.3.1\n- braces (npm): affected from 2.2.0; fixed in 2.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1109/ (Markdown: https://insights.sbomify.com/CVE-2018-1109/index.md)","id":"CVE-2018-1109","markdown":"https://insights.sbomify.com/CVE-2018-1109/index.md","name":"CVE-2018-1109","record":{"aliases":["GHSA-cwfw-4gq5-mrqx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the Braces library via Regular Expression Denial of Service attacks.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"braces","vendor":"braces_project"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-185","name":"Incorrect Regular Expression"}],"description":"A vulnerability was found in Braces versions 2.2.0 and above, prior to 2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service (ReDoS) in braces","id":"CVE-2018-1109","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in knot-resolver","id":"CVE-2018-1110"},"packages":[{"ecosystem":"npm","fixed":["2.3.1"],"introduced":["2.2.0"],"last_affected":[],"package":"braces","purl":null,"source":"GHSA-cwfw-4gq5-mrqx"},{"ecosystem":"npm","fixed":["2.3.1"],"introduced":["2.2.0"],"last_affected":[],"package":"braces","purl":"pkg:npm/braces","source":"GHSA-cwfw-4gq5-mrqx"}],"prev":{"headline":"Information disclosure in drivers","id":"CVE-2018-1108"},"products":["nodejs-braces"],"published":"2021-03-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-12-01","vendors":["n/a"]},"summary":"Attackers can cause denial of service in applications using the Braces library via Regular Expression Denial of Service attacks.","url":"https://insights.sbomify.com/CVE-2018-1109/"}