# CVE-2018-1109: Regular Expression Denial of Service (ReDoS) in braces

> Attackers can cause denial of service in applications using the Braces library via Regular Expression Denial of Service attacks.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2021
- **Updated:** 1 Dec 2025
- **Also known as:** GHSA-cwfw-4gq5-mrqx

## What is CVE-2018-1109?

CVE-2018-1109 is a medium-severity denial of service vulnerability in nodejs-braces, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in Braces versions 2.2.0 and above, prior to 2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-185 (Incorrect Regular Expression)

## Which versions are affected by CVE-2018-1109?

2 open source packages ship an affected version, including braces. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `braces` | npm | From 2.2.0 | 2.3.1 |
| `braces` | npm | From 2.2.0 | 2.3.1 |

Products: Braces Project Braces.

## How do I fix CVE-2018-1109?

Upgrade braces to 2.3.1 or later.

## Is CVE-2018-1109 being exploited?

There is no known exploitation of CVE-2018-1109 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1109 and fix it if it is affected.

What it is: CVE-2018-1109 is a medium-severity denial of service vulnerability in nodejs-braces, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1109 in the wild and no public exploit code.

Affected packages and fixed versions:
- braces (npm): affected from 2.2.0; fixed in 2.3.1
- braces (npm): affected from 2.2.0; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1109/ (Markdown: https://insights.sbomify.com/CVE-2018-1109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1109
- OSV: https://osv.dev/vulnerability/CVE-2018-1109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1109/
Summaries are generated and may contain mistakes; the official description above is the record.
