# CVE-2018-11093: Cross-Site Scripting in @ckeditor/ckeditor5-link

> Remote attackers can inject arbitrary web script via crafted link attributes in the CKEditor 5 Link package, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gvpx-9459-w3mj

## What is CVE-2018-11093?

CVE-2018-11093 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the Link package for CKEditor 5 before 10.0.1 allows remote attackers to inject arbitrary web script through a crafted href attribute of a link (A) element.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-11093?

2 open source packages ship an affected version, including @ckeditor/ckeditor5-link. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@ckeditor/ckeditor5-link` | npm | From 0.3.0 | 10.0.1 |
| `@ckeditor/ckeditor5-link` | npm | From 0.3.0 | 10.0.1 |

Products: Ckeditor Ckeditor 5-Link.

## How do I fix CVE-2018-11093?

Upgrade @ckeditor/ckeditor5-link to 10.0.1 or later.

## Is CVE-2018-11093 being exploited?

There is no known exploitation of CVE-2018-11093 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11093 and fix it if it is affected.

What it is: CVE-2018-11093 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-11093 in the wild and no public exploit code.

Affected packages and fixed versions:
- @ckeditor/ckeditor5-link (npm): affected from 0.3.0; fixed in 10.0.1
- @ckeditor/ckeditor5-link (npm): affected from 0.3.0; fixed in 10.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11093/ (Markdown: https://insights.sbomify.com/CVE-2018-11093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11093
- OSV: https://osv.dev/vulnerability/CVE-2018-11093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11093/
Summaries are generated and may contain mistakes; the official description above is the record.
