{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-1115 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-1115 is a medium-severity missing authorization vulnerability in Opensuse Leap, published on 10 May 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1115 and fix it if it is affected.\n\nWhat it is: CVE-2018-1115 is a medium-severity missing authorization vulnerability in Opensuse Leap, published on 10 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1115 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1115/ (Markdown: https://insights.sbomify.com/CVE-2018-1115/index.md)","id":"CVE-2018-1115","markdown":"https://insights.sbomify.com/CVE-2018-1115/index.md","name":"CVE-2018-1115","record":{"aliases":["ALPINE-CVE-2018-1115","CLEANSTART-2026-SF26103","GHSA-54w7-jv4g-qhqg","SUSE-SU-2018:1695-1","UBUNTU-CVE-2018-1115"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["security_bypass","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"PostgreSQL adminpack extension","requires_auth":"low_privilege","summary":"An attacker with database access can bypass ACLs in the adminpack extension to force log rotation, potentially causing denial of service.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"postgresql","vendor":"postgresql"}],"cvss":{"score":4.2,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing authorization in postgresql","id":"CVE-2018-1115","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap","postgresql:postgresql"],"type":"missing_authorization","year":"2018"},"n_packages":7,"n_references":7,"next":{"headline":"Missing authorization in polkit","id":"CVE-2018-1116"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["9.6.9-3.19.1"],"introduced":["0"],"last_affected":[],"package":"postgresql96","purl":"pkg:rpm/suse/postgresql96\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:1695-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["9.6.9-3.19.1"],"introduced":["0"],"last_affected":[],"package":"postgresql96-libs","purl":"pkg:rpm/suse/postgresql96-libs\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:1695-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["9.6.9-3.19.1"],"introduced":["0"],"last_affected":[],"package":"postgresql96","purl":"pkg:rpm/suse/postgresql96\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:1695-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["9.6.9-3.19.1"],"introduced":["0"],"last_affected":[],"package":"postgresql96-libs","purl":"pkg:rpm/suse/postgresql96-libs\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:1695-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["9.6.9-3.19.1"],"introduced":["0"],"last_affected":[],"package":"postgresql96","purl":"pkg:rpm/suse/postgresql96\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:1695-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["9.6.9-3.19.1"],"introduced":["0"],"last_affected":[],"package":"postgresql96-libs","purl":"pkg:rpm/suse/postgresql96-libs\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:1695-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["9.6.9-3.19.1"],"introduced":["0"],"last_affected":[],"package":"postgresql96-libs","purl":"pkg:rpm/suse/postgresql96-libs\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:1695-1"}],"prev":{"headline":"Uncontrolled Resource Consumption in Undertow","id":"CVE-2018-1114"},"products":["postgresql"],"published":"2018-05-10","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["unspecified"]},"summary":"An attacker with database access can bypass ACLs in the adminpack extension to force log rotation, potentially causing denial of service.","url":"https://insights.sbomify.com/CVE-2018-1115/"}