# CVE-2018-11307: Deserialization of Untrusted Data in jackson-databind

> Attackers can exploit unsafe deserialization in Jackson with iBatis gadgets to exfiltrate data or execute code if default typing is enabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jul 2019
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-EL43307, DEBIAN-CVE-2018-11307, GHSA-qr7j-h6gg-jmgc, ROOT-APP-MAVEN-CVE-2018-11307, UBUNTU-CVE-2018-11307

## What is CVE-2018-11307?

CVE-2018-11307 is a critical unsafe deserialization vulnerability in Fasterxml Jackson-Databind, published on 9 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in FasterXML jackson-databind 2.0.0 through 2.9.5. Use of Jackson default typing along with a gadget class from iBatis allows exfiltration of content. Fixed in 2.7.9.4, 2.8.11.2, and 2.9.6.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-11307?

6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.7.9.4 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.7.9.4 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.2 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.2 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.6 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.6 |

Products: Fasterxml Jackson-Databind, Oracle Clusterware, Oracle Communications Instant Messaging Server, Oracle Global Lifecycle Management Opatch, Oracle Retail Customer Management and Segmentation Foundation, Oracle Utilities Advanced Spatial and Operational Analytics, Redhat Openshift Container Platform.

## How do I fix CVE-2018-11307?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.7.9.4, 2.8.11.2 or 2.9.6.

## Is CVE-2018-11307 being exploited?

There is no known exploitation of CVE-2018-11307 in the wild and no public exploit code.

## Other vulnerabilities in Fasterxml Jackson-Databind

- [CVE-2026-54512](https://insights.sbomify.com/CVE-2026-54512/): jackson-databind: PolymorphicTypeValidator bypass via generic type parameters allows arbitrary class instantiation (high 8.1)
- [CVE-2026-54513](https://insights.sbomify.com/CVE-2026-54513/): jackson-databind: Array subtype allowlist bypass in BasicPolymorphicTypeValidator (allowIfSubTypeIsArray) (high 8.1)
- [CVE-2020-14060](https://insights.sbomify.com/CVE-2020-14060/): Deserialization of untrusted data in Jackson Databind (high 8.1)
- [CVE-2021-46877](https://insights.sbomify.com/CVE-2021-46877/): jackson-databind possible Denial of Service if using JDK serialization to serialize JsonNode (high 7.5)
- [CVE-2019-14893](https://insights.sbomify.com/CVE-2019-14893/): Polymorphic deserialization of malicious object in jackson-databind (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11307 and fix it if it is affected.

What it is: CVE-2018-11307 is a critical unsafe deserialization vulnerability in Fasterxml Jackson-Databind, published on 9 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-11307 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.7.9.4
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.7.9.4
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.2
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.2
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.6
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11307/ (Markdown: https://insights.sbomify.com/CVE-2018-11307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11307
- OSV: https://osv.dev/vulnerability/CVE-2018-11307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11307/
Summaries are generated and may contain mistakes; the official description above is the record.
