# CVE-2018-1131: Deserialization of Untrusted Data in Infinispan

> Authenticated users can achieve code execution by sending malicious objects to caches configured with specific transcoders in Infinispan.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qqfc-m9hc-pqv3

## What is CVE-2018-1131?

CVE-2018-1131 is a high-severity unsafe deserialization vulnerability in Red Hat, Inc. infinispan, published on 15 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Infinispan permits improper deserialization of trusted data via XML and JSON transcoders under certain server configurations. A user with authenticated access to the server could send a malicious object to a cache configured to accept certain types of objects, achieving code execution and possible further attacks. Versions 9.0.3.Final, 9.1.7.Final, 8.2.10.Final, 9.2.2.Final, 9.3.0.Alpha1 are believed to be affected.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-349 (Acceptance of Extraneous Untrusted Data With Trusted Data)

## Which versions are affected by CVE-2018-1131?

4 open source packages ship an affected version, including org.infinispan:infinispan-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.infinispan:infinispan-core` | Maven | All versions | None |
| `org.infinispan:infinispan-core` | Maven | All versions | None |
| `org.infinispan:infinispan-core` | Maven | From 9.3.0.Alpha1 | 9.3.1.Final |
| `org.infinispan:infinispan-core` | Maven | From 9.3.0.Alpha1 | 9.3.1.Final |

Products: Infinispan Infinispan, Redhat Jboss Data Grid.

## How do I fix CVE-2018-1131?

Upgrade org.infinispan:infinispan-core to 9.3.1.Final or later.

## Is CVE-2018-1131 being exploited?

There is no known exploitation of CVE-2018-1131 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat, Inc. infinispan

- [CVE-2017-15089](https://insights.sbomify.com/CVE-2017-15089/): Deserialization of Untrusted Data in Infinispan (high 8.8)
- [CVE-2019-10174](https://insights.sbomify.com/CVE-2019-10174/): Use of Externally-Controlled Input to Select Classes or Code in Infinispan (high 7.5)
- [CVE-2023-5384](https://insights.sbomify.com/CVE-2023-5384/): Infinispan: credentials returned from configuration as clear text (high 7.2)
- [CVE-2023-3628](https://insights.sbomify.com/CVE-2023-3628/): Infispan: rest bulk ops don't check permissions (medium 6.5)
- [CVE-2020-25711](https://insights.sbomify.com/CVE-2020-25711/): Improper Access Control in infinispan-server-runtime (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1131 and fix it if it is affected.

What it is: CVE-2018-1131 is a high-severity unsafe deserialization vulnerability in Red Hat, Inc. infinispan, published on 15 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1131 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.infinispan:infinispan-core (Maven): affected all versions; no fix listed
- org.infinispan:infinispan-core (Maven): affected all versions; no fix listed
- org.infinispan:infinispan-core (Maven): affected from 9.3.0.Alpha1; fixed in 9.3.1.Final
- org.infinispan:infinispan-core (Maven): affected from 9.3.0.Alpha1; fixed in 9.3.1.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1131/ (Markdown: https://insights.sbomify.com/CVE-2018-1131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1131
- OSV: https://osv.dev/vulnerability/CVE-2018-1131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1131/
Summaries are generated and may contain mistakes; the official description above is the record.
