# CVE-2018-11317: Subrion CMS XSS


- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-2cmg-vxvh-8h7h

## What is CVE-2018-11317?

CVE-2018-11317 is a medium-severity vulnerability in n/a, published on 3 Jul 2019. 

### Official description

Subrion CMS before 4.1.4 has XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-11317?

2 open source packages ship an affected version, including intelliants/subrion. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `intelliants/subrion` | Packagist | All versions | 4.1.4 |
| `intelliants/subrion` | Packagist | All versions | 4.1.4 |

Products: Intelliants Subrion.

## How do I fix CVE-2018-11317?

Upgrade intelliants/subrion to 4.1.4 or later.

## Is CVE-2018-11317 being exploited?

There is no known exploitation of CVE-2018-11317 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-25400](https://insights.sbomify.com/CVE-2024-25400/): SQL injection in n/a (critical 9.8)
- [CVE-2020-18155](https://insights.sbomify.com/CVE-2020-18155/): SQL Injection in Subrion CMS (critical 9.8)
- [CVE-2017-5543](https://insights.sbomify.com/CVE-2017-5543/): Subrion CMS PHP Object Injection (critical 9.8)
- [CVE-2023-46947](https://insights.sbomify.com/CVE-2023-46947/): Subrion remote command execution vulnerability (high 8.8)
- [CVE-2018-21037](https://insights.sbomify.com/CVE-2018-21037/): Subrion CMS CSRF Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11317 and fix it if it is affected.

What it is: CVE-2018-11317 is a medium-severity vulnerability in n/a, published on 3 Jul 2019. 
Exploitation: There is no known exploitation of CVE-2018-11317 in the wild and no public exploit code.

Affected packages and fixed versions:
- intelliants/subrion (Packagist): affected all versions; fixed in 4.1.4
- intelliants/subrion (Packagist): affected all versions; fixed in 4.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11317/ (Markdown: https://insights.sbomify.com/CVE-2018-11317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11317
- OSV: https://osv.dev/vulnerability/CVE-2018-11317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11317/
Summaries are generated and may contain mistakes; the official description above is the record.
