{"answers":{"affected":"2 open source packages ship an affected version, including joomla/joomla-cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-11326 in the wild and no public exploit code.","fix":"Upgrade joomla/joomla-cms to 3.8.8 or later.","what":"CVE-2018-11326 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\\!, published on 22 May 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-11326 and fix it if it is affected.\n\nWhat it is: CVE-2018-11326 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\\!, published on 22 May 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-11326 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- joomla/joomla-cms (Packagist): affected from 3.0.0; fixed in 3.8.8\n- joomla/joomla-cms (Packagist): affected from 3.0.0; fixed in 3.8.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-11326/ (Markdown: https://insights.sbomify.com/CVE-2018-11326/index.md)","id":"CVE-2018-11326","markdown":"https://insights.sbomify.com/CVE-2018-11326/index.md","name":"CVE-2018-11326","record":{"aliases":["GHSA-g3m5-vvj7-xrwv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Joomla CMS","requires_auth":"high_privilege","summary":"Inadequate input filtering in Joomla allows attackers to execute cross-site scripting attacks, potentially compromising user accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"joomla\\!","vendor":"joomla"}],"cvss":{"score":4.8,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in Joomla! Core before 3.8.8. Inadequate input filtering leads to a multiple XSS vulnerabilities. Additionally, the default filtering settings could potentially allow users of the default Administrator user group to perform a XSS attack.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Joomla! XSS Vulnerability","id":"CVE-2018-11326","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"joomla:joomla\\!","products":["joomla:joomla\\!"],"type":"xss","year":"2018"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in n/a","id":"CVE-2018-11327"},"packages":[{"ecosystem":"Packagist","fixed":["3.8.8"],"introduced":["3.0.0"],"last_affected":[],"package":"joomla/joomla-cms","purl":null,"source":"GHSA-g3m5-vvj7-xrwv"},{"ecosystem":"Packagist","fixed":["3.8.8"],"introduced":["3.0.0"],"last_affected":[],"package":"joomla/joomla-cms","purl":"pkg:composer/joomla/joomla-cms","source":"GHSA-g3m5-vvj7-xrwv"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2018-11325"},"products":["n/a"],"published":"2018-05-22","related":[{"cvss_score":9.8,"headline":"PHPMailer Command Injection","id":"CVE-2016-10033","kev_date_added":"2025-07-07","published":"2016-12-30"},{"cvss_score":5.3,"headline":"Joomla! Improper Access Control","id":"CVE-2023-23752","kev_date_added":"2024-01-08","published":"2023-02-16"},{"cvss_score":9.8,"headline":"Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links","id":"CVE-2026-48902","kev_date_added":null,"published":"2026-05-26"},{"cvss_score":9.8,"headline":"[20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package","id":"CVE-2025-25226","kev_date_added":null,"published":"2025-04-08"},{"cvss_score":9.8,"headline":"[20220303] - Core - User row are not bound to a authentication mechanism","id":"CVE-2022-23795","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"[20220305] - Core - Inadequate filtering on the selected Ids","id":"CVE-2022-23797","kev_date_added":null,"published":"2022-03-30"},{"cvss_score":9.8,"headline":"[20220307] - Core - Variable Tampering on JInput $_REQUEST data","id":"CVE-2022-23799","kev_date_added":null,"published":"2022-03-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Inadequate input filtering in Joomla allows attackers to execute cross-site scripting attacks, potentially compromising user accounts.","url":"https://insights.sbomify.com/CVE-2018-11326/"}