# CVE-2018-11326: Joomla! XSS Vulnerability

> Inadequate input filtering in Joomla allows attackers to execute cross-site scripting attacks, potentially compromising user accounts.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-g3m5-vvj7-xrwv

## What is CVE-2018-11326?

CVE-2018-11326 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 22 May 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Joomla! Core before 3.8.8. Inadequate input filtering leads to a multiple XSS vulnerabilities. Additionally, the default filtering settings could potentially allow users of the default Administrator user group to perform a XSS attack.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-11326?

2 open source packages ship an affected version, including joomla/joomla-cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `joomla/joomla-cms` | Packagist | From 3.0.0 | 3.8.8 |
| `joomla/joomla-cms` | Packagist | From 3.0.0 | 3.8.8 |

Products: Joomla Joomla\!.

## How do I fix CVE-2018-11326?

Upgrade joomla/joomla-cms to 3.8.8 or later.

## Is CVE-2018-11326 being exploited?

There is no known exploitation of CVE-2018-11326 in the wild and no public exploit code.

## Other vulnerabilities in Joomla Joomla\!

- [CVE-2016-10033](https://insights.sbomify.com/CVE-2016-10033/): PHPMailer Command Injection (critical 9.8, exploited in the wild)
- [CVE-2023-23752](https://insights.sbomify.com/CVE-2023-23752/): Joomla! Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-48902](https://insights.sbomify.com/CVE-2026-48902/): Joomla! Core - [20260518] - Transport encryption downgrade for password and username reset links (critical 9.8)
- [CVE-2025-25226](https://insights.sbomify.com/CVE-2025-25226/): [20250401] - Joomla Framework - SQL injection vulnerability in quoteNameStr method of Database package (critical 9.8)
- [CVE-2022-23795](https://insights.sbomify.com/CVE-2022-23795/): [20220303] - Core - User row are not bound to a authentication mechanism (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11326 and fix it if it is affected.

What it is: CVE-2018-11326 is a medium-severity cross-site scripting vulnerability in Joomla Joomla\!, published on 22 May 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-11326 in the wild and no public exploit code.

Affected packages and fixed versions:
- joomla/joomla-cms (Packagist): affected from 3.0.0; fixed in 3.8.8
- joomla/joomla-cms (Packagist): affected from 3.0.0; fixed in 3.8.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11326/ (Markdown: https://insights.sbomify.com/CVE-2018-11326/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11326
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11326
- OSV: https://osv.dev/vulnerability/CVE-2018-11326

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11326/
Summaries are generated and may contain mistakes; the official description above is the record.
