CVE-2018-1133 Moodle calculated question type allows remote code execution by Question authors
A teacher can achieve remote code execution on the server by injecting malicious code into Calculated questions in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1133?
CVE-2018-1133 is a high-severity code injection vulnerability in Moodle Moodle, published on 25 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Moodle 3.x. A Teacher creating a Calculated question can intentionally cause remote code execution on the server, aka eval injection.
Weakness: CWE-94
Which versions are affected by CVE-2018-1133?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.12 |
moodle/moodle Packagist | From 3.1 | 3.1.12 |
moodle/moodle Packagist | From 3.2 | 3.2.9 |
moodle/moodle Packagist | From 3.2 | 3.2.9 |
moodle/moodle Packagist | From 3.3 | 3.3.6 |
moodle/moodle Packagist | From 3.3 | 3.3.6 |
2 more packages
moodle/moodle Packagist | From 3.4 | 3.4.3 |
moodle/moodle Packagist | From 3.4 | 3.4.3 |
Products include Moodle Moodle.
How do I fix CVE-2018-1133?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.12, 3.2.9, 3.3.6 or 3.4.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2018-1133 being exploited?
There is no known exploitation of CVE-2018-1133 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry and 3 proofs of concept on GitHub.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-xh2j-q4mc-v522, UBUNTU-CVE-2018-1133.