CVE-2018-11352 Wallabag cross-site scripting (XSS) vulnerability
Stored XSS in Wallabag allows authenticated attackers to execute JavaScript in admin sessions, potentially stealing credentials or hijacking accounts.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-11352?
CVE-2018-11352 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.
Weakness: CWE-79
Which versions are affected by CVE-2018-11352?
2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
wallabag/wallabag Packagist | From 2.2.3 | 2.3.3 |
wallabag/wallabag Packagist | From 2.2.3 | 2.3.3 |
Products include Wallabag Wallabag.
How do I fix CVE-2018-11352?
Upgrade wallabag/wallabag to 2.3.3 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-11352 being exploited?
There is no known exploitation of CVE-2018-11352 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-gvcw-x64m-pfcj.