{"answers":{"affected":"2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-11352 in the wild and no public exploit code.","fix":"Upgrade wallabag/wallabag to 2.3.3 or later.","what":"CVE-2018-11352 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-11352 and fix it if it is affected.\n\nWhat it is: CVE-2018-11352 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-11352 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wallabag/wallabag (Packagist): affected from 2.2.3; fixed in 2.3.3\n- wallabag/wallabag (Packagist): affected from 2.2.3; fixed in 2.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-11352/ (Markdown: https://insights.sbomify.com/CVE-2018-11352/index.md)","id":"CVE-2018-11352","markdown":"https://insights.sbomify.com/CVE-2018-11352/index.md","name":"CVE-2018-11352","record":{"aliases":["GHSA-gvcw-x64m-pfcj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Wallabag application","requires_auth":"high_privilege","summary":"Stored XSS in Wallabag allows authenticated attackers to execute JavaScript in admin sessions, potentially stealing credentials or hijacking accounts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"wallabag","vendor":"wallabag"}],"cvss":{"score":4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Wallabag cross-site scripting (XSS) vulnerability","id":"CVE-2018-11352","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-11354"},"packages":[{"ecosystem":"Packagist","fixed":["2.3.3"],"introduced":["2.2.3"],"last_affected":[],"package":"wallabag/wallabag","purl":null,"source":"GHSA-gvcw-x64m-pfcj"},{"ecosystem":"Packagist","fixed":["2.3.3"],"introduced":["2.2.3"],"last_affected":[],"package":"wallabag/wallabag","purl":"pkg:composer/wallabag/wallabag","source":"GHSA-gvcw-x64m-pfcj"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-11351"},"products":["n/a"],"published":"2018-09-21","related":[{"cvss_score":7.3,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0734","kev_date_added":null,"published":"2023-03-05"},{"cvss_score":6.5,"headline":"CSRF in wallabag/wallabag","id":"CVE-2023-0737","kev_date_added":null,"published":"2024-11-15"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in wallabag/wallabag","id":"CVE-2023-4455","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":6.5,"headline":"Cross-Site Request Forgery (CSRF) in wallabag/wallabag","id":"CVE-2023-0735","kev_date_added":null,"published":"2023-02-07"},{"cvss_score":6.5,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0609","kev_date_added":null,"published":"2023-02-01"},{"cvss_score":5.4,"headline":"Improper Authorization in wallabag/wallabag","id":"CVE-2023-0610","kev_date_added":null,"published":"2023-02-01"},{"cvss_score":4.6,"headline":"Cross-site Scripting (XSS) - Stored in wallabag/wallabag","id":"CVE-2023-0736","kev_date_added":null,"published":"2023-02-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Stored XSS in Wallabag allows authenticated attackers to execute JavaScript in admin sessions, potentially stealing credentials or hijacking accounts.","url":"https://insights.sbomify.com/CVE-2018-11352/"}