# CVE-2018-11352: Wallabag cross-site scripting (XSS) vulnerability

> Stored XSS in Wallabag allows authenticated attackers to execute JavaScript in admin sessions, potentially stealing credentials or hijacking accounts.

- **Severity:** Medium 4.0 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gvcw-x64m-pfcj

## What is CVE-2018-11352?

CVE-2018-11352 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Wallabag application 2.2.3 to 2.3.2 is affected by one cross-site scripting (XSS) vulnerability that is stored within the configuration page. This vulnerability enables the execution of a JavaScript payload each time an administrator visits the configuration page. The vulnerability can be exploited with authentication and used to target administrators and steal their sessions.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-11352?

2 open source packages ship an affected version, including wallabag/wallabag. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wallabag/wallabag` | Packagist | From 2.2.3 | 2.3.3 |
| `wallabag/wallabag` | Packagist | From 2.2.3 | 2.3.3 |

Products: Wallabag Wallabag.

## How do I fix CVE-2018-11352?

Upgrade wallabag/wallabag to 2.3.3 or later.

## Is CVE-2018-11352 being exploited?

There is no known exploitation of CVE-2018-11352 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-0734](https://insights.sbomify.com/CVE-2023-0734/): Improper Authorization in wallabag/wallabag (high 7.3)
- [CVE-2023-0737](https://insights.sbomify.com/CVE-2023-0737/): CSRF in wallabag/wallabag (medium 6.5)
- [CVE-2023-4455](https://insights.sbomify.com/CVE-2023-4455/): Cross-Site Request Forgery (CSRF) in wallabag/wallabag (medium 6.5)
- [CVE-2023-0735](https://insights.sbomify.com/CVE-2023-0735/): Cross-Site Request Forgery (CSRF) in wallabag/wallabag (medium 6.5)
- [CVE-2023-0609](https://insights.sbomify.com/CVE-2023-0609/): Improper Authorization in wallabag/wallabag (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-11352 and fix it if it is affected.

What it is: CVE-2018-11352 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-11352 in the wild and no public exploit code.

Affected packages and fixed versions:
- wallabag/wallabag (Packagist): affected from 2.2.3; fixed in 2.3.3
- wallabag/wallabag (Packagist): affected from 2.2.3; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-11352/ (Markdown: https://insights.sbomify.com/CVE-2018-11352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-11352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-11352
- OSV: https://osv.dev/vulnerability/CVE-2018-11352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-11352/
Summaries are generated and may contain mistakes; the official description above is the record.
