CVE-2018-1136 Moodle Cross-site Scripting
Authenticated users can inject malicious scripts into shared pages via movable HTML blocks, enabling cross-site scripting attacks against other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1136?
CVE-2018-1136 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Moodle 3.x. An authenticated user is allowed to add HTML blocks containing scripts to their Dashboard; this is normally not a security issue because a personal dashboard is visible to this user only. Through this security vulnerability, users can move such a block to other pages where they can be viewed by other users.
Weakness: CWE-79
Which versions are affected by CVE-2018-1136?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.12 |
moodle/moodle Packagist | From 3.1 | 3.1.12 |
moodle/moodle Packagist | From 3.2 | 3.2.9 |
moodle/moodle Packagist | From 3.2 | 3.2.9 |
moodle/moodle Packagist | From 3.3 | 3.3.6 |
moodle/moodle Packagist | From 3.3 | 3.3.6 |
2 more packages
moodle/moodle Packagist | From 3.4 | 3.4.3 |
moodle/moodle Packagist | From 3.4 | 3.4.3 |
Products include Moodle Moodle.
How do I fix CVE-2018-1136?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.12, 3.2.9, 3.3.6 or 3.4.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1136 being exploited?
There is no known exploitation of CVE-2018-1136 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-xhfw-wjjc-4j5h, UBUNTU-CVE-2018-1136.