# CVE-2018-1136: Moodle Cross-site Scripting

> Authenticated users can inject malicious scripts into shared pages via movable HTML blocks, enabling cross-site scripting attacks against other users.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-xhfw-wjjc-4j5h, UBUNTU-CVE-2018-1136

## What is CVE-2018-1136?

CVE-2018-1136 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in Moodle 3.x. An authenticated user is allowed to add HTML blocks containing scripts to their Dashboard; this is normally not a security issue because a personal dashboard is visible to this user only. Through this security vulnerability, users can move such a block to other pages where they can be viewed by other users.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1136?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.12 |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.12 |
| `moodle/moodle` | Packagist | From 3.2 | 3.2.9 |
| `moodle/moodle` | Packagist | From 3.2 | 3.2.9 |
| `moodle/moodle` | Packagist | From 3.3 | 3.3.6 |
| `moodle/moodle` | Packagist | From 3.3 | 3.3.6 |
| `moodle/moodle` | Packagist | From 3.4 | 3.4.3 |
| `moodle/moodle` | Packagist | From 3.4 | 3.4.3 |

Products: Moodle Moodle.

## How do I fix CVE-2018-1136?

Upgrade moodle/moodle to a fixed version for your release line: 3.1.12, 3.2.9, 3.3.6 or 3.4.3.

## Is CVE-2018-1136 being exploited?

There is no known exploitation of CVE-2018-1136 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1136 and fix it if it is affected.

What it is: CVE-2018-1136 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1136 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.12
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.12
- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.9
- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.9
- moodle/moodle (Packagist): affected from 3.3; fixed in 3.3.6
- moodle/moodle (Packagist): affected from 3.3; fixed in 3.3.6
- moodle/moodle (Packagist): affected from 3.4; fixed in 3.4.3
- moodle/moodle (Packagist): affected from 3.4; fixed in 3.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1136/ (Markdown: https://insights.sbomify.com/CVE-2018-1136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1136
- OSV: https://osv.dev/vulnerability/CVE-2018-1136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1136/
Summaries are generated and may contain mistakes; the official description above is the record.
