CVE-2018-1137 Moodle Portfolio script allows instantiation of class chosen by user
Authenticated users can instantiate arbitrary classes via portfolio URLs, enabling code execution or denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1137?
CVE-2018-1137 is a high-severity code injection vulnerability in Moodle Moodle, published on 25 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in Moodle 3.x. By substituting URLs in portfolios, users can instantiate any class. This can also be exploited by users who are logged in as guests to create a DDoS attack.
Weakness: CWE-20
Which versions are affected by CVE-2018-1137?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 3.1 | 3.1.12 |
moodle/moodle Packagist | From 3.1 | 3.1.12 |
moodle/moodle Packagist | From 3.2 | 3.2.9 |
moodle/moodle Packagist | From 3.2 | 3.2.9 |
moodle/moodle Packagist | From 3.3 | 3.3.6 |
moodle/moodle Packagist | From 3.3 | 3.3.6 |
2 more packages
moodle/moodle Packagist | From 3.4 | 3.4.3 |
moodle/moodle Packagist | From 3.4 | 3.4.3 |
Products include Moodle Moodle.
How do I fix CVE-2018-1137?
Upgrade moodle/moodle to a fixed version for your release line: 3.1.12, 3.2.9, 3.3.6 or 3.4.3.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2018-1137 being exploited?
There is no known exploitation of CVE-2018-1137 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-vxqh-mx28-7ghw, UBUNTU-CVE-2018-1137.