{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1137 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 3.1.12, 3.2.9, 3.3.6 or 3.4.3.","what":"CVE-2018-1137 is a high-severity code injection vulnerability in Moodle Moodle, published on 25 May 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1137 and fix it if it is affected.\n\nWhat it is: CVE-2018-1137 is a high-severity code injection vulnerability in Moodle Moodle, published on 25 May 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1137 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.12\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.12\n- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.9\n- moodle/moodle (Packagist): affected from 3.2; fixed in 3.2.9\n- moodle/moodle (Packagist): affected from 3.3; fixed in 3.3.6\n- moodle/moodle (Packagist): affected from 3.3; fixed in 3.3.6\n- moodle/moodle (Packagist): affected from 3.4; fixed in 3.4.3\n- moodle/moodle (Packagist): affected from 3.4; fixed in 3.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1137/ (Markdown: https://insights.sbomify.com/CVE-2018-1137/index.md)","id":"CVE-2018-1137","markdown":"https://insights.sbomify.com/CVE-2018-1137/index.md","name":"CVE-2018-1137","record":{"aliases":["GHSA-vxqh-mx28-7ghw","UBUNTU-CVE-2018-1137"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Authenticated users can instantiate arbitrary classes via portfolio URLs, enabling code execution or denial of service.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in Moodle 3.x. By substituting URLs in portfolios, users can instantiate any class. This can also be exploited by users who are logged in as guests to create a DDoS attack.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Portfolio script allows instantiation of class chosen by user","id":"CVE-2018-1137","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"code_injection","year":"2018"},"n_packages":8,"n_references":2,"next":{"headline":"Weak cryptography in samba","id":"CVE-2018-1139"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.12"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vxqh-mx28-7ghw"},{"ecosystem":"Packagist","fixed":["3.1.12"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vxqh-mx28-7ghw"},{"ecosystem":"Packagist","fixed":["3.2.9"],"introduced":["3.2"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vxqh-mx28-7ghw"},{"ecosystem":"Packagist","fixed":["3.2.9"],"introduced":["3.2"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vxqh-mx28-7ghw"},{"ecosystem":"Packagist","fixed":["3.3.6"],"introduced":["3.3"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vxqh-mx28-7ghw"},{"ecosystem":"Packagist","fixed":["3.3.6"],"introduced":["3.3"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vxqh-mx28-7ghw"},{"ecosystem":"Packagist","fixed":["3.4.3"],"introduced":["3.4"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-vxqh-mx28-7ghw"},{"ecosystem":"Packagist","fixed":["3.4.3"],"introduced":["3.4"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-vxqh-mx28-7ghw"}],"prev":{"headline":"Moodle Cross-site Scripting","id":"CVE-2018-1136"},"products":["Moodle 3.x unknown"],"published":"2018-05-25","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated users can instantiate arbitrary classes via portfolio URLs, enabling code execution or denial of service.","url":"https://insights.sbomify.com/CVE-2018-1137/"}